Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83718 - redhat-config-network crashes when saving changes
Summary: redhat-config-network crashes when saving changes
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 16:05 UTC by Maurice Powers
Modified: 2008-05-01 15:38 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:08:16 UTC


Attachments (Terms of Use)
ifcfg-lo(calhost) file (deleted)
2003-02-07 16:45 UTC, Maurice Powers
no flags Details
Adapter eth0 config file (deleted)
2003-02-07 16:46 UTC, Maurice Powers
no flags Details
This is the change that I am attempting. (deleted)
2003-02-07 16:56 UTC, Maurice Powers
no flags Details
Error message itself (deleted)
2003-02-07 16:57 UTC, Maurice Powers
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Maurice Powers 2003-02-07 16:05:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20021120
Netscape/7.01

Description of problem:
When I attempt to make a change to the RedHat network configuration, I get an
Unhandled Exception occurrence.  The changes that were attempted to be made are
not saved as well.

This is the second time that I have installed Redhat 8.0.  The first time I had
no problems such as this.  This also started occurring BEFORE I updated this
installation with the up2date program, but continues to occur after obtaining
all of the updates.




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open Network Configurator (redhat-config-network)
2.Make a change to the settings
3.Attempt to save the changes by either pressing Apply or Close (Then save).
    

Actual Results:  An unhandled exception occurs and the changes are not saved.

Expected Results:  No program crash, my network changes would have been saved.

Additional info:

Here is the file dump that is generated:

Traceback (most recent call last):
  File "/usr/sbin/neat", line 496, in on_applyButton_clicked
    self.save()
  File "/usr/sbin/neat", line 319, in save
    self.saveDevices()
  File "/usr/sbin/neat", line 326, in saveDevices
    devicelist.save()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/NCDeviceList.py",
line 145, in save
    os.write(fp2, ipc.network()+'/'+ipc.prefix()+" via "+route.Gateway+"\n")
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 58,
in network
    self.prefix()
  File "/usr/sbin/../share/redhat-config-network/netconfpkg/ipcalc.py", line 37,
in prefix
    self._netmask = re.match("NETMASK=(\S+)", text).groups()[0]
AttributeError: 'NoneType' object has no attribute 'groups'

Local variables in innermost frame:
text: 
self: <netconfpkg.ipcalc.IPCalc instance at 0x8563674>

Comment 1 Harald Hoyer 2003-02-07 16:08:21 UTC
did you forget to specify a netmask in any device?



Comment 2 Maurice Powers 2003-02-07 16:30:41 UTC
Version of redhat-config-network is: 1.1.20-1

I did not forget the netmask on the network adapter.  There is only one adapter
in this computer as well.  My networking seems to work just fine, yet, I wanted
to add an additional DNS server.

This MIGHT be a duplicate of #83396.  But the dump that I got was a bit
different than that report...therefore I decided to submit.

Comment 3 Harald Hoyer 2003-02-07 16:33:47 UTC
can you please attach your ifcfg-??? file?


Comment 4 Maurice Powers 2003-02-07 16:45:19 UTC
Created attachment 89927 [details]
ifcfg-lo(calhost) file

Comment 5 Maurice Powers 2003-02-07 16:46:03 UTC
Created attachment 89928 [details]
Adapter eth0 config file

Comment 6 Harald Hoyer 2003-02-07 16:49:11 UTC
err ok ... :)
then please describe or make a snapshot of your settings, which you try to save,
that I can reproduce them..

Comment 7 Maurice Powers 2003-02-07 16:56:41 UTC
Created attachment 89929 [details]
This is the change that I am attempting.

I am new to this whole Linux GUI thing.  I haven't used Linux since 1998 and I
wasn't very good with it back then!  LOL!  Anyhow, here is the screen shot for
the change that I am attempting.  I will include the next screen shot of the
error that I get.

Comment 8 Maurice Powers 2003-02-07 16:57:22 UTC
Created attachment 89930 [details]
Error message itself

This error message will show when I press the Apply button.

Comment 9 Maurice Powers 2003-02-07 17:24:52 UTC
Here is what I get when I run the redhat-config-network from a terminal session.
 It will open the program initiall, and I guess copies the /etc/resolv.conf
file.  After I apply the changes, then I get the readout listed beginning on the
4th line of the included text:

[root@bemidji default]# redhat-config-network
Copying /etc/resolv.conf to default profile.

** (neat:12272): WARNING **: could not find handler `on_cancelButton_clicked'

** (neat:12272): WARNING **: could not find handler `on_deviceNameEntry_insert_t
ext'

** (neat:12272): WARNING **: could not find handler `on_okButton_clicked'

** (neat:12272): WARNING **: could not find handler `on_deviceNameEntry_changed'

** (neat:12272): WARNING **: could not find handler `on_routeAddButton_clicked'

** (neat:12272): WARNING **: could not find handler `on_routeDeleteButton_clicke
d'

** (neat:12272): WARNING **: could not find handler `on_routeEditButton_clicked'

** (neat:12272): WARNING **: could not find handler `on_hardwareAliasesToggle_to
ggled'

** (neat:12272): WARNING **: could not find handler `on_hardwareProbeButton_clic
ked'

** (neat:12272): WARNING **: could not find handler `on_hardwareMACToggle_toggle
d'

** (neat:12272): WARNING **: could not find handler `on_hardwareAliasesToggle_to
ggled'

** (neat:12272): WARNING **: could not find handler `on_ipStaticRadio_toggled'

** (neat:12272): WARNING **: could not find handler `on_ipAutomaticRadio_toggled
'

** (neat:12272): WARNING **: could not find handler `on_hardwareProbeButton_clic
ked'

** (neat:12272): WARNING **: could not find handler `on_hardwareMACToggle_toggle
d'

** (neat:12272): WARNING **: could not find handler `on_routeAddButton_clicked'

** (neat:12272): WARNING **: could not find handler `on_routeDeleteButton_clicke
d'

** (neat:12272): WARNING **: could not find handler `on_routeEditButton_clicked'

** (neat:12272): WARNING **: could not find handler `on_ipStaticRadio_toggled'

** (neat:12272): WARNING **: could not find handler `on_ipAutomaticRadio_toggled
'
ipcalc: ip address expected


Comment 10 Need Real Name 2003-02-22 19:42:07 UTC
I have almost exact same problem

Comment 13 Bion Smalley 2003-04-03 21:21:14 UTC
I, too, have the same problem:  redhat-config-network crashes whenever ANY
change is made and either OK or APPLY is clicked.  I can supply the dump file
and the text of the error messages if necessary, but the problem is so general
that you should already have enough to go on.

Comment 14 Harald Hoyer 2003-08-11 14:08:16 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.