Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83717 - closes pane immediately after opening passwd file with pop3 users
Summary: closes pane immediately after opening passwd file with pop3 users
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 15:10 UTC by Ken Patching
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-07 21:17:13 UTC


Attachments (Terms of Use)

Description Ken Patching 2003-02-07 15:10:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
origin: RH7.3 pulbic download release. running sendmail and ipop3d.
users configured as pop users only.
Redhat-config-users opened and correctly showed pop user names.

Applied RH 8.0 upgrade to our mailserver.
Redhat-config-users opened and then imediately closes. Suggest RH7.3 passwd / 
group file incompaitability with RH8.0

Tried on two separate RH 7.3 i686 test systems same result.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create RH7.3 system with pop only users
2.upgrade to rh8.0
3.run redhat-config-users
    

Actual Results:  redhat-config-users fails to open and show pop users. Program 
opens window and then closes it again.

Expected Results:  window should stay open showing users and pop usesrs.

Additional info:

Comment 1 Ken Patching 2003-02-07 17:11:33 UTC
I would like to correct some miss information on the bug report 83717.

The upgrade was from rh 7.1 and not 7.3. In addition the original user and 
group files were maintained by linuxconf and not redhat-config-users. 

After running redhat-config-users and then existing gnome(X11 windows) back to 
a command prompt. The exit report from XFree86 shows :
file "/usr/share/redhat-config-users gidNumber = userEnt.get(libuser.GIDNUMBER)
[0] IndexError: list index out of range.

This I think points to a passwd file structure / definition incompaitability 
between linuxconf and redhat-config-users.

Ken Patching 17:09 UTC 07/02/03 

Comment 2 Brent Fox 2003-02-07 21:17:13 UTC
There's not an easy way for me to reproduce this bug.  There's no telling how
linuxconf might have messed up /etc/passwd, /etc/shadow, and/or /etc/group so
that libuser (the backend that redhat-config-users uses) can't read the files. 
One of the main reasons we stopped shipping linuxconf a few releases ago was
it's unpredictability.  

I know this isn't the answer you want to hear but I really can't afford to spend
the time necessary to track down the cause of this problem, especially since we
don't ship linuxconf anymore.  Closing as 'wontfix'.


Note You need to log in before you can comment on or make changes to this bug.