Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83700 - vim becomes a runaway process
Summary: vim becomes a runaway process
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
: 61141 78350 83177 88458 91629 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 06:25 UTC by Danny Sung
Modified: 2007-04-18 16:50 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-07-21 14:42:45 UTC


Attachments (Terms of Use)

Description Danny Sung 2003-02-07 06:25:28 UTC
I can consistently make vim become a runaway process by loading it in a window
and closing the window in which it was created.  This happens either locally or
remotely (either in a xterm/gnome-terminal or through a putty/ssh session). 
I've seen this for several versions of redhat (I think since 6.2, but I'm not
sure).  I'm using the latest version right now, 6.1-18.7x.2.  It only seems to
happen to the vim-enhanced version, however, and not vim-minimal.  Rebuilding
from the src.rpm produces the same affect.

Comment 1 Tim Tregubov 2003-05-22 16:50:30 UTC
I can do the same, in fact we have several general login servers which consistently get loaded up 
with runnaway vim and xemacs processes both of which seem to hang in the same consistent 
manner.    All you gotta do is ssh into a box, start vim, close your terminal without quitting vim...  

I've seen this on 7.2-9.0 machines...

Comment 2 Tim Tregubov 2003-05-22 17:01:07 UTC
never mind just found this on the vim page:
http://vimdoc.sourceforge.net/cgi-bin/vimfaq2html3.pl

29.9. When I kill the xterm running Vim, the Vim process continues to run
      and takes up a lot of CPU (99%) time. Why is this happening?

When Vim is built with support for Python interface, you will have this
problem. This is a known problem with a python thread library and Vim.  To
solve this problem, use a Vim binary built without the Python interface.

For more information, read

    :help +python
    :help python


Doesn't look like there is a fix yet...

Cheers,
Tim

Comment 3 Karsten Hopp 2003-05-30 12:57:58 UTC
*** Bug 91629 has been marked as a duplicate of this bug. ***

Comment 4 Karsten Hopp 2003-06-20 11:49:04 UTC
*** Bug 88458 has been marked as a duplicate of this bug. ***

Comment 5 Karsten Hopp 2003-06-20 11:50:08 UTC
*** Bug 83177 has been marked as a duplicate of this bug. ***

Comment 6 Karsten Hopp 2003-06-20 11:51:43 UTC
*** Bug 78350 has been marked as a duplicate of this bug. ***

Comment 7 Karsten Hopp 2003-06-20 12:00:35 UTC
*** Bug 61141 has been marked as a duplicate of this bug. ***

Comment 8 John Hardin 2003-09-25 17:33:06 UTC
This is happening to us, too. 

dkl, can we get a fixed vim built and released? Or perhaps a fixed Python thread
library if vim +python is too useful to lose?

Thanks.


Note You need to log in before you can comment on or make changes to this bug.