Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83684 - Compile errors when trying to build modules
Summary: Compile errors when trying to build modules
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 8.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-07 02:26 UTC by Ted Kaczmarek
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-05 14:43:22 UTC


Attachments (Terms of Use)
text file (deleted)
2003-02-07 02:31 UTC, Ted Kaczmarek
no flags Details

Description Ted Kaczmarek 2003-02-07 02:26:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20030202

Description of problem:
Modules fail to compile, when trying to apply USB patch for Phillips web cam.
Their seems to be an error when it get to building the cipe module.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cp pwc-8.8 patch to /usr/src/linux-2.4.18-24.8.0/drivers/usb
2. Make Dep
3. Make modules
    

Actual Results:  Compile errors

Expected Results:  Modules compile ok.

Additional info:

This patch only affect the usb drivers and worked fine on the
linux-2.4.18-19.8.0 kernel.
http://www.smcc.demon.nl/webcam/
I understand totally the issues, so use this info as you feel fit.

I will upload file with compile error output.

Comment 1 Ted Kaczmarek 2003-02-07 02:31:24 UTC
Created attachment 89917 [details]
text file

Hope this is helpful, anything else I can do to be of help feel free to ask.

Comment 2 Arjan van de Ven 2003-02-07 09:22:27 UTC
looks like you forgot make mrproper etc as first steps

Comment 3 Ted Kaczmarek 2003-02-08 01:46:09 UTC
Make mrproper, make clean, make xconfig, load config from
/boot/config-2.4.18-24.8.0smp(this was config created after kernel upgrade)
, make dep, make modules, poops out by srv3/4 binary support.


Comment 4 Ted Kaczmarek 2003-02-09 22:02:55 UTC
Turns out that up2date when I first went to 2-4.18-24.8 did not up2date
kernel-utils to kernel-utils-2.4-8.28. After updating kernel-utils I am not
experiencing any more issues with compiling. You can close this out, I was not
sure how to identify resolution, was guessing upstream but I'll leave that for you
to determine.


Note You need to log in before you can comment on or make changes to this bug.