Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83677 - "unpack tuple of wrong size" in readonly rescue mode
Summary: "unpack tuple of wrong size" in readonly rescue mode
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-02-07 00:20 UTC by John Reiser
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-07 16:26:56 UTC


Attachments (Terms of Use)

Description John Reiser 2003-02-07 00:20:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
Rescue mode crashed when trying to mount a root partition (1 of 2) readonly.


Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Install RHL7.3 with separate / and /home and /extra partitions each as ext3.
2.Install Phoebe using /extra as new, formatted / as ext3, but mount same /home
ext3 keeping old contents.
3.Reboot RHL7.3, which will drop into maintenance mode when trying to mount
/extra because it has an unknown attribute (dir_index).
4.Boot Phoebe CD-ROM 1 as "linux rescue", specify the Phoebe root, atttempt to
mount it Read-only.

Actual Results:  "Blue screen of death" with [laddered because LF with no CR]:
Traceback (most recent call last)
File "/usr/bin/anaconda", line 319, in ?   rescue.runRescue(rootPath, not
rescue.nomount, id)
File "/usr/lib/anaconda/resuce.ph", line 130 in runRescue     for(drive, fs) in
disks:
Value Error: unpack tuple of wrong size
install exited abnormally

[Above traceback was transcribed by hand.]


Expected Results:  Phoebe root should have been mounted readonly, and no crash.

Additional info:

I worked around the problem by selecting Skip instead of Read-only.  Then I
could remove the dir_index attribute from the Phoebe root, e2fsck -fD, check all
filesystems, reboot with RHL8.0 rescue mode, check all filesystems, and finally
reboot into RHL7.3.  It's a bummer that switching back-and-forth between RHL7.3
and Phoebe has these quirks.

Comment 1 Jeremy Katz 2003-02-07 16:26:56 UTC
Fixed in CVS already


Note You need to log in before you can comment on or make changes to this bug.