Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83607 - noatun can not play ogg vorbis audio files
Summary: noatun can not play ogg vorbis audio files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: arts
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-06 08:04 UTC by Michael Wardle
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-05 10:07:48 UTC


Attachments (Terms of Use)

Description Michael Wardle 2003-02-06 08:04:21 UTC
Description of problem: 
Noatun can not play ogg vorbis audio files. 
 
Version-Release number of selected component (if applicable): 
kdemultimedia-3.1-0.3 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Add Ogg Vorbis audio files to Noatun playlist 
2. Attempt to play files 
     
Actual results: 
Each Ogg Vorbis file entry in the playlist is highlighted for a few seconds, no sound is heard, 
then the playlist skips to the next song. 
 
Expected results: 
File is played. 
 
Additional info: 
A similar bug on the KDE bug system suggests this could be because artsd was not compiled 
with support for libogg and libvorbis.

Comment 1 Michael Wardle 2003-02-06 08:09:33 UTC
This is the output from artsd when trying to play an Ogg Vorbis file: 
----- 
loading extension from '/usr/lib/libartsgslplayobject.la' failed: file not found 
MCOP ObjectManager: Could not load extension libartsgslplayobject.la. 
MCOP ObjectManager: can't find implementation for Arts::GSLPlayObject. 
Segmentation fault 
----- 
 
Reassigning to arts component based on above suspicion. 
 
Installed version is arts-1.1.0-2. 
 

Comment 2 Ngo Than 2003-02-06 10:42:54 UTC
it's fixed in arts-1.1-4/kdemultimedia-3.1-0.7 or newer. It works for me.

Comment 3 Michael Wardle 2003-02-27 23:47:34 UTC
This is happening again with Phoebe 3 
arts-1.1-5 
kdemultimedia-3.1-2 
 

Comment 4 Ngo Than 2003-02-28 14:21:50 UTC
does it work for you, if you install arts-devel package?

Comment 5 Mary Ellen Foster 2003-03-01 11:40:25 UTC
I had this exact problem (Phoebe3), and yes, installing arts-devel created the
necessary library to allow noatun to play .ogg files.

MEF

Comment 6 Ngo Than 2003-03-05 10:07:48 UTC
It's fixed in 1.1-8 or later


Note You need to log in before you can comment on or make changes to this bug.