Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83570 - [RFE] Allow historic patch levels with up2date
Summary: [RFE] Allow historic patch levels with up2date
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adrian Likins
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-05 17:57 UTC by Rich Snyder
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-02 19:16:54 UTC


Attachments (Terms of Use)

Description Rich Snyder 2003-02-05 17:57:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020501

Description of problem:
It would be very desirable to allow up2date to be passed a date for a box to be
brought up to the patch level as of that date.

The reason behind this is that customers do not allways want their servers
brought up to date every month or so because they have put a lot of effort into
testing their apps with a particular level of rpms.  If they would like a
duplicate of a box that is, say 3 months out of date with patches, there is no
way to create a duplicate level of patches using up2date.  Another use for this
is that rebuilds take far less time than doing a complete restore from tape.  If
we could build a box and then tell up2date to bring the patches up to the last
update of the server that crashed, then only user content would need to be
reloaded from tape.  Additionally, it would be great for building a box to
attempt to duplicate an error that occured with a previous patch level.

Basically, it would be very desireable for up2date to support historic patch
levels instead of just the most up-to-date patches.

up2date --patchdate 01-01-2003

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
N/A

Additional info:


Note You need to log in before you can comment on or make changes to this bug.