Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83560 - ATA100 doesn't work; only getting ATA33. Missing "ide=ata66"?????
Summary: ATA100 doesn't work; only getting ATA33. Missing "ide=ata66"?????
Keywords:
Status: CLOSED DUPLICATE of bug 83546
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-05 16:53 UTC by Aaron Freed
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:37 UTC


Attachments (Terms of Use)

Description Aaron Freed 2003-02-05 16:53:12 UTC
Description of problem:
Unable to get true ATA100 performance from RedHat 7.3.  No matter what I do with
hdparm, I still get about 22 MB/sec transfer rate from the ATA100 IDE drive,
which is about what I get from my other two systems, both of which are only
ATA33-capable.

Version-Release number of selected component (if applicable):


How reproducible:
Guaranteed.  Cannot get any better performance! ;-<

Steps to Reproduce:
1.Install RedHat 7.3
2.Boot.  
3.Run hdparm -t /dev/hda1 as root
4.See poor result.
5.Be disappointed.

I seem to recall that there was a parameter I could pass to the kernel during
the boot process, by appending it to the end of the appropriate line in
/etc/grub.conf like this: (added parameter highlighted by "^^^^^^^^^"



    title Red Hat Linux (2.4.18-24.7.xbigmem)
        root (hd0,0)
        kernel /vmlinuz-2.4.18-24.7.xbigmem ro root=/dev/hda2 hdc=ide-scsi ide=ata66
^^^^^^^^^
        initrd /initrd-2.4.18-24.7.xbigmem.img


Actual results:

Have not tried it, yet.  Don't want to trash the central server with an
incorrect parameter!

Expected results:
data transfer rate of > 40 MB/s, as reported by hdparm -t /dev/hda

Additional info:
I know I reported this once before and Dave Ledford (I think?) kindly sent me
the instructions regarding a parameter similar to the above that fixed all my
problems and brought about World Peace (almost), but I cannot find that e-mail
or the original bug.  I'm really sorry to bother you with this again, and I
really do appreciate it!

Comment 1 Arjan van de Ven 2003-02-05 16:55:21 UTC

*** This bug has been marked as a duplicate of 83546 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.