Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83557 - volume applet looks bad in bluecurve
Summary: volume applet looks bad in bluecurve
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-artwork
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79579 CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-02-05 16:20 UTC by Alexander Larsson
Modified: 2007-04-18 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-07-31 17:53:16 UTC


Attachments (Terms of Use)

Description Alexander Larsson 2003-02-05 16:20:34 UTC
If you use the bluecurve icon theme the volume applet look really bad at 48x48.
It looks like the icon is scaled up from 16x16. Other themes look ok.

Comment 1 Havoc Pennington 2003-02-05 16:25:07 UTC
oh, I thought it was just a dup of bug 82301, if it's a theme bug we should 
be able to fix it easily.

Garrett - we need a larger volume icon.

Comment 2 Alexander Larsson 2003-02-05 16:27:34 UTC
Nah, bug 82301 is about launchers. This one is fine if you change the theme.


Comment 3 Alexander Larsson 2003-02-05 16:34:51 UTC
the volume applet is using the stock icons:
#define VOLUME_STOCK_MUTE             "volume-mute"
#define VOLUME_STOCK_ZERO	      "volume-zero"
#define VOLUME_STOCK_MIN              "volume-min"
#define VOLUME_STOCK_MED              "volume-med"
#define VOLUME_STOCK_MAX              "volume-max"

data->zero = gtk_widget_render_icon (data->applet, VOLUME_STOCK_ZERO,
					     volume_icon_size, NULL);
data->min = gtk_widget_render_icon (data->applet, VOLUME_STOCK_MIN,
					     volume_icon_size, NULL);
data->med = gtk_widget_render_icon (data->applet, VOLUME_STOCK_MED,
					     volume_icon_size, NULL);
data->max = gtk_widget_render_icon (data->applet, VOLUME_STOCK_MAX,
					     volume_icon_size, NULL);
data->muted = gtk_widget_render_icon (data->applet, VOLUME_STOCK_MUTE,
					     volume_icon_size, NULL);


Comment 4 Garrett LeSage 2003-02-05 16:44:09 UTC
Okay, this is the third time I'm trying to post to this bug. Bugzilla keeps
eating the comments and giving me errors. (It seems to mostly work fine when I
comment on other bugs, however. Maybe it just doesn't like me today...)

Anyway,

We have three solutions here:

* Fix the volume applet so it doesn't scale the icons
* Make 48x48 versions that just enlarge the space around the 24x24 versions
* Adapt the 48x48 version of the icon for the stock icon theme

Of course, there's also:

* Use SVG for everything

(But that's not an option yet. *grin*)

Comment 5 Matt Wilson 2003-02-05 19:11:16 UTC
I *don't* want a 48x48 applet for twiddling my volume!


Comment 6 Miloslav Trmac 2003-02-17 18:09:29 UTC
Bug 83175 seems to be a duplicate of this
(I can't add a comment there)

Comment 7 Garrett LeSage 2003-07-31 16:25:56 UTC
There are now multiple sizes of the volume indicator in redhat-artwork. The
configuration or the actual code may need to be changed; but artwork is in place.

Comment 8 Matt Wilson 2003-07-31 17:53:16 UTC
works in RHL 9 - think it was fixed for 8.0 too.



Note You need to log in before you can comment on or make changes to this bug.