Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83548 - The keybord is unavailable during installation
Summary: The keybord is unavailable during installation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu
Version: phoebe
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-05 15:43 UTC by Joerg Anders
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-07 20:33:48 UTC


Attachments (Terms of Use)

Description Joerg Anders 2003-02-05 15:43:02 UTC
Description of problem:   
During installation the keyboard is unavailable as soon   
as the installation process starts X11    
The mouse works.   
   
   
Version-Release number of selected component (if applicable):   
phobe-i386-disc1.iso   
   
   
How reproducible: I have 15 computers with Board K7 Triton 400/GA-7VA   
Athlon 2200+. At every computer the keyboard is not  
available as soon as the installation 
process sarts X11. BTW: It IS availabel on psyche-8.0!  
   
   
Steps to Reproduce:   
1. insert CD-ROM with "phoebe-i386-disc1.iso" 
2. proceed installation process till X11 is started 
3. Press any key --> nothing happens 
       
Actual results:   
The Red Hat users have to learn to use the computer without keyboard. 
   
   
Expected results:   
If I press a key on keyboard (for instance 192.168.10.1 for 
network konfiguration) the appropriate signs should appear at screen. 
   
   
Additional info:

Comment 1 Michael Fulbright 2003-02-06 15:21:14 UTC
If you hit cntl-alt-f2 does it switch to a text command screen?

Comment 2 Bill Nottingham 2003-02-06 16:53:05 UTC
This should be fixed in current trees.

Comment 3 Joerg Anders 2003-02-06 19:01:59 UTC
I can hit hit cntl-alt-f2: nothing happens. Even if I press 
cntl-alt-backspace: nothing happens. An nothing happens 
if I press cntl-alt-del. 
 
BTW: I've forgotten: I use PS2 keyboard and USB mouse. 
 
I hope the last answer is authoritative! 

Comment 4 Michael Fulbright 2003-02-06 20:25:09 UTC
If you boot with 'linux text' you will see a text based install interface. Does
you keyboard work then?

Comment 5 Joerg Anders 2003-02-07 09:12:54 UTC
It dosn't work if I use: linux text 
The installation proceeds and the  
keyboard works till a screen appears "Wilcome to RedHat Linux..." 
And I shall choose "OK" or "Back". But I can't do 
anything because the keyboard has no effect. I can 
press <Return> or <Tab> even crtl+alt+del --> nothing happens! 
 
Again: I have 15 computers with Board K7 Triton 400/GA-7VA  
and Athlon 2200+. I can choose any of these computers randomly. 
The keyboard has no effect. But note! All works with psyche-8.0. (???) 
 
Perhaps I can give a hint. There are some related news: 
http://www.cs.helsinki.fi/linux/linux-kernel/2002-50/0226.html 
http://www.cs.helsinki.fi/linux/linux-kernel/2002-50/0255.html 
 
http://www.uwsg.iu.edu/hypermail/linux/kernel/0212.1/0891.html 
 
Perhaps this helps! 
 
 

Comment 6 Michael Fulbright 2003-02-07 20:24:45 UTC
Apparently this is a kernel issue.

Comment 7 Arjan van de Ven 2003-02-07 20:31:20 UTC
it's not.

Comment 8 Bill Nottingham 2003-02-07 20:33:48 UTC
This should be fixed in current trees.


Note You need to log in before you can comment on or make changes to this bug.