Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83546 - ATA100 doesn't work; only getting ATA33. Missing "ide=ata66"?????
Summary: ATA100 doesn't work; only getting ATA33. Missing "ide=ata66"?????
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
: 83560 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-05 15:41 UTC by Aaron Freed
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-09-30 15:40:29 UTC


Attachments (Terms of Use)

Description Aaron Freed 2003-02-05 15:41:50 UTC
Description of problem:
Unable to get true ATA100 performance from RedHat 7.3.  No matter what I do with
hdparm, I still get about 22 MB/sec transfer rate from the ATA100 IDE drive,
which is about what I get from my other two systems, both of which are only
ATA33-capable.

Version-Release number of selected component (if applicable):


How reproducible:
Guaranteed.  Cannot get any better performance! ;-<

Steps to Reproduce:
1.Install RedHat 7.3
2.Boot.  
3.Run hdparm -t /dev/hda1 as root
4.See poor result.
5.Be disappointed.

I seem to recall that there was a parameter I could pass to the kernel during
the boot process, by appending it to the end of the appropriate line in
/etc/grub.conf like this: (added parameter highlighted by "^^^^^^^^^"



    title Red Hat Linux (2.4.18-24.7.xbigmem)
        root (hd0,0)
        kernel /vmlinuz-2.4.18-24.7.xbigmem ro root=/dev/hda2 hdc=ide-scsi ide=ata66
^^^^^^^^^
        initrd /initrd-2.4.18-24.7.xbigmem.img


Actual results:

Have not tried it, yet.  Don't want to trash the central server with an
incorrect parameter!

Expected results:
data transfer rate of > 40 MB/s, as reported by hdparm -t /dev/hda

Additional info:
I know I reported this once before and Dave Ledford (I think?) kindly sent me
the instructions regarding a parameter similar to the above that fixed all my
problems and brought about World Peace (almost), but I cannot find that e-mail
or the original bug.  I'm really sorry to bother you with this again, and I
really do appreciate it!

Comment 1 Arjan van de Ven 2003-02-05 15:58:55 UTC
the actual parameter is
ide0=ata66
for the first "cable", ide1=ata66 for the second cable etc etc.
Only do this if you have the 80 ribbon cable! 

Comment 2 Arjan van de Ven 2003-02-05 16:55:24 UTC
*** Bug 83560 has been marked as a duplicate of this bug. ***

Comment 3 Aaron Freed 2003-02-05 19:05:29 UTC
Thanks!  That seems to have sped things up a bit!  Can I get even more bang with
"ide=ata100", or does "ide=ata66" already include that?

Thanks again, Arjan!

Comment 4 Arjan van de Ven 2003-02-05 21:22:02 UTC
ide0=ata66 already includes that. the only thing that matters is 40 vs 80 ribbon
cable; something that not always can be autodetected.

Comment 5 Bugzilla owner 2004-09-30 15:40:29 UTC
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/



Note You need to log in before you can comment on or make changes to this bug.