Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83539 - pygtk2 compiled without thread support
Summary: pygtk2 compiled without thread support
Keywords:
Status: CLOSED DUPLICATE of bug 80908
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pygtk2
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-05 14:59 UTC by Tor Andre Myrvoll
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:37 UTC


Attachments (Terms of Use)

Description Tor Andre Myrvoll 2003-02-05 14:59:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Trying to use pygtk2 in a multithreaded python program dont work.

Example

dhcp-2130:WoZ$python
Python 2.2.1 (#1, Aug 30 2002, 12:15:30)
[GCC 3.2 20020822 (Red Hat Linux Rawhide 3.2-4)] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk
>>> gtk.threads_init()
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
RuntimeError: pygtk threading disabled at compile time
>>>

The effect of this is that _all_ other threads will freeze when 
gtk.mainloop() is run.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start python 
2. import threads/threadings and gtk
3. Start a new thread using either the threads or threading modules
4. Start gtk.mainloop()

Actual Results:  The initial threads will freeze

Expected Results:  All the threads should coexist peacefully

Additional info:

Comment 1 Gary Benson 2003-05-12 11:38:13 UTC
I've been running pygtk2 rebuilt with threads for the past five months and had
no problems.

Comment 2 Matt Wilson 2003-05-20 03:53:30 UTC

*** This bug has been marked as a duplicate of 80908 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:37 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.