Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83493 - hwbrowser exits uncleanly
Summary: hwbrowser exits uncleanly
Keywords:
Status: CLOSED DUPLICATE of bug 74956
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: hwbrowser
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-04 21:33 UTC by Michael A. Peters
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:36 UTC


Attachments (Terms of Use)

Description Michael A. Peters 2003-02-04 21:33:50 UTC
Description of problem:
hwbrowser crashes on Asus A7N8X Deluxe motherboard

Version-Release number of selected component (if applicable):
0.6-1

How reproducible:
every time

Steps to Reproduce:
1. Install A7N8X Deluxe motherboard
2. log in
3. /usr/bin/hwbrowser
    
Actual results:
Asks for root password, starts to display window, dies with a bunch of errors in
the terminal.

(DeviceList.py:12201): GnomeCanvas-CRITICAL **: file gnome-canvas-path-def.c:
line 1142 (gnome_canvas_path_def_any_closed): assertion `path != NULL' failed

is repeated a bunch of times - followed by

Traceback (most recent call last):
  File "/usr/share/hwbrowser/DeviceList.py", line 203, in ?
    reread_device_type_list ()
  File "/usr/share/hwbrowser/DeviceList.py", line 150, in reread_device_type_list
    list.set (iter, 0, hardware.get_category_string (key), 1, key)
  File "/usr/share/hwbrowser/DeviceList.py", line 91, in get_category_string
    return self.type_mapping[key]
KeyError: 20



Expected results:
It should either work or exit nicely if it is not capable of browsing my hardware.


Additional info:
This application worked fine on this same install of RH Linux on a Asus VIA
motherboard with a Athlon 900. The cpu on that board died :(

I built a new box with the A7N8X Deluxe board.
In addition to changing the board, I added a slave hard drive to primary bus and
a slave dvd drive to secondary IDE bus.

Old config:
VIA slot A Athlon board (ath 900 128mb PC 100)
2 PCI nics, Soundblaster Live, US Robotics PCI modem
hda: RHLinux
hdb: empty
hdc: sony cdrw
hdd: kenwood TrueX cdrom
vid: VooDoo3 AGP

New config:
A7N8X Deluxe (ath xp 2700+ - 256mb PC3200)
2 onboard nics and onboard audio
US Robotics PCI modem (same as above)
hda: RHLinux (same as above)
hdb: RHLinux (new drive - well, was my old RH 7.1 drive)
hdc: sony cdrw (same as above)
hdd: dvd drive (new- forget brand)
vid: AOpen nVidia GF4 440SE

-=-
I'm running a custom kernel - http://homepage.mac.com/mpeters/A7N8X/ but this
issues also happens when I boot into the stock RH kernel - so its not a kernel
issue. I think its just the A7N8X board.

Comment 1 Brent Fox 2003-02-04 21:57:44 UTC

*** This bug has been marked as a duplicate of 74956 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:36 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.