Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83467 - profiling stylesheets don't work
Summary: profiling stylesheets don't work
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: docbook-style-xsl
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-04 17:48 UTC by Tammy Fox
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-09 16:18:59 UTC


Attachments (Terms of Use)
sample DocBook XML file with profiles (deleted)
2003-02-04 17:50 UTC, Tammy Fox
no flags Details

Description Tammy Fox 2003-02-04 17:48:50 UTC
With DocBook XML, you are supposed to be able to create profiles
to conditionalize text as documented in 
/usr/share/doc/docbook-style-xsl-<version>/doc/tools/profiling.html.

However, of the three default profiling XSL stylesheets in
/usr/share/sgml/docbook/xsl-stylesheets/html/ (all three
start with profile-), only profile-chunk.xml works, and even
it produces runtime errors.

Sample command:
xsltproc -stringparam "profile.arch" "x86-common;x86-base"
/usr/share/sgml/docbook/xsl-stylesheets/html/profile-chunk.xsl sample.xml

Summary:
1) profile-chunk.xml produces HTML files with proper conditionalization, but
gives the following output:
runtime error: file /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl
line 239 element apply-templates
xsltApplyOneTemplate: loop found ???
try increasing xsltMaxDepth (--maxdepth)
Templates:
#0 name * name head.keywords.content
#1 name * name head.keywords.content
#2 name * name head.keywords.content
#3 name * name head.keywords.content
#4 name * name head.keywords.content
#5 name * name head.keywords.content
#6 name * name head.keywords.content
#7 name * name head.keywords.content
#8 name * name head.keywords.content
#9 name * name head.keywords.content
#10 name * name head.keywords.content
#11 name * name head.keywords.content
#12 name * name head.keywords.content
#13 name * name head.keywords.content
#14 name * name head.keywords.content
Variables:
Writing ch01.html for chapter(ch-setup-sgml-catalog)
runtime error: file /usr/share/sgml/docbook/xsl-stylesheets/html/docbook.xsl
line 239 element apply-templates
xsltApplyOneTemplate: loop found ???
try increasing xsltMaxDepth (--maxdepth)
Templates:
#0 name * name head.keywords.content
#1 name * name head.keywords.content
#2 name * name head.keywords.content
#3 name * name head.keywords.content
#4 name * name head.keywords.content
#5 name * name head.keywords.content
#6 name * name head.keywords.content
#7 name * name head.keywords.content
#8 name * name head.keywords.content
#9 name * name head.keywords.content
#10 name * name head.keywords.content
#11 name * name head.keywords.content
#12 name * name head.keywords.content
#13 name * name head.keywords.content
#14 name * name head.keywords.content
Variables:
Writing bk01.html for book(index)
no result for sample.xml

2) profile-docbook.xsl produces no HTML files and gives:
runtime error: file
/usr/share/sgml/docbook/xsl-stylesheets/html/profile-docbook.xsl line 219
element apply-templates
xsltApplyOneTemplate: loop found ???
try increasing xsltMaxDepth (--maxdepth)
Templates:
#0 name * name head.keywords.content
#1 name * name head.keywords.content
#2 name * name head.keywords.content
#3 name * name head.keywords.content
#4 name * name head.keywords.content
#5 name * name head.keywords.content
#6 name * name head.keywords.content
#7 name * name head.keywords.content
#8 name * name head.keywords.content
#9 name * name head.keywords.content
#10 name * name head.keywords.content
#11 name * name head.keywords.content
#12 name * name head.keywords.content
#13 name * name head.keywords.content
#14 name * name head.keywords.content
Variables:
no result for sample.xml

3) profile-onechunk.xsl produces HTML files thar are not properly
conditionalized and gives:
runtime error: file
/usr/share/sgml/docbook/xsl-stylesheets/html/profile-docbook.xsl line 219
element apply-templates
xsltApplyOneTemplate: loop found ???
try increasing xsltMaxDepth (--maxdepth)
Templates:
#0 name * name head.keywords.content
#1 name * name head.keywords.content
#2 name * name head.keywords.content
#3 name * name head.keywords.content
#4 name * name head.keywords.content
#5 name * name head.keywords.content
#6 name * name head.keywords.content
#7 name * name head.keywords.content
#8 name * name head.keywords.content
#9 name * name head.keywords.content
#10 name * name head.keywords.content
#11 name * name head.keywords.content
#12 name * name head.keywords.content
#13 name * name head.keywords.content
#14 name * name head.keywords.content
Variables:
no result for sample.xml
[tfox@ijin profiling]$ ls
sample.xml
[tfox@ijin profiling]$ xsltproc -stringparam "profile.arch"
"x86-common;x86-base"
/usr/share/sgml/docbook/xsl-stylesheets/html/profile-onechunk.xsl sample.xml
Writing index.html for book(index)

Comment 1 Tammy Fox 2003-02-04 17:50:13 UTC
Created attachment 89841 [details]
sample DocBook XML file with profiles

Comment 2 Tim Waugh 2003-05-09 09:21:02 UTC
This seems to have been a problem with libxslt/libxml2; the current rawhide
package behave okay.

Comment 3 Tammy Fox 2003-05-09 16:08:55 UTC
With docbook-style-xsl-1.60.1-1, libxslt-1.0.30-2, and libxml2-2.5.7-2:

1) profile-docbook.xsl outputs correctly profiled HTML to stdout

2) profile-chunk.xsl outputs correctly profiled HTML in chunks

3) profile-onechunk.xsl produces HTML with all content instead of just the
content I specified to include (and it produces a Next link even though the
output is one page, but that is a different bug ;-) )

Looks like profile-onechunk.xsl is still broken.

Comment 4 Tim Waugh 2003-05-09 16:13:52 UTC
Confirmed, and it's still broken in 1.61.0 upstream.

Comment 5 Tim Waugh 2003-05-09 16:18:59 UTC
Reported upstream.


Note You need to log in before you can comment on or make changes to this bug.