Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83462 - Users with NFS home directory cannot log in
Summary: Users with NFS home directory cannot log in
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-desktop
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-04 17:14 UTC by jay
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-04 19:01:01 UTC


Attachments (Terms of Use)

Description jay 2003-02-04 17:14:20 UTC
Description of problem:
Users whose home directory is on an nfs-mounted disk cannot login. The message 
box states Could not lock /users/jay/.gconf-test-locking-file.  The /users disk
resides on a Tru-64 Unix system. The error box suggests that nfslock may be 
disabled, but it is enabled. It says that the error reported is Permission 
Denied (errno=13).  I even tried giving the Red Hat system root privelege on 
this disk, but it made no difference.  The problem occurs only with Linux 8.0; 
all previous Red Hat Linux systems were able to log in without problems. This 
has made version 8.0 completely unusable for us, since all of our users have 
their home directories mounted remotely.


Version-Release number of selected component (if applicable):
Red Hat Linux 8.0

How reproducible:


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Havoc Pennington 2003-02-04 19:01:01 UTC
http://www.gnome.org/projects/gconf/ has a workaround, search for 
GCONF_LOCAL_LOCKS.

Other than that all you can really do is get Tru64 NFS fixed to support locking. 
POSIX locking has been standard for many many years, and NFS is supposed to 
support it.

We have a long term plan to avoid the need to lock in the user's home directory, 
but not something that can be fixed simply.


Note You need to log in before you can comment on or make changes to this bug.