Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83428 - First time boot error after RH8.1 Beta 4 installation.
Summary: First time boot error after RH8.1 Beta 4 installation.
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-04 04:27 UTC by Larry Troan
Modified: 2016-04-18 09:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:35 UTC


Attachments (Terms of Use)
firsttime.jpg (deleted)
2003-02-04 04:28 UTC, Larry Troan
no flags Details

Description Larry Troan 2003-02-04 04:27:25 UTC
First time boot error after RH8.1 Beta 4 installation.

Operating System: Red Hat 8.1 Beta 4

Details:
Server (and Generation): All

Steps to reproduce:
1) Install Red Hat 8.1 Beta 4 (grub) 
2) After base installation is completed, system reboots and X server starts
   up.  
3) Pop-up window on black background "An error has occurred in the Data and
   Time module.
4) This is followed by a Traceback and prompt to report to bugzilla.
5) See the attached image firsttime.jpg for a picture of the error.
6) Contents of the firstboot.1030230371.23 specified in the image is here:

Traceback (most recent call last):
  File "/usr/share/firstboot/firstbootWindow.py", line 153, in __init__
    vbox, eventbox = module.launch()
  File "/usr/share/firstboot/modules/date.py", line 75, in launch
    self.setupScreen()
  File "/usr/share/firstboot/modules/date.py", line 64, in setupScreen
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

7) This happens on all servers the first time the system boots after an 
install only.  After that, the system seems to work normally.  This is new
with Beta 4 and not seen previously.

Is the issue reproducible? yes 

Workaround: no
----------
Action by: Bryan.Leopard
Issue Registered
----------
Action by: Bryan.Leopard


Status set to: Waiting on Tech
File uploaded: firsttime.jpg


ISSUE TRACKER 14887, opened as sev 2.

Comment 1 Larry Troan 2003-02-04 04:28:21 UTC
Created attachment 89829 [details]
firsttime.jpg

Comment 2 Jeremy Katz 2003-02-04 15:58:29 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:35 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.