Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83418 - redhat-config-date crashes on beta 4.
Summary: redhat-config-date crashes on beta 4.
Keywords:
Status: CLOSED DUPLICATE of bug 82061
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 9
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-04 03:12 UTC by Larry Troan
Modified: 2016-04-18 09:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:35 UTC


Attachments (Terms of Use)

Description Larry Troan 2003-02-04 03:12:59 UTC
redhat-config-date crashes on beta 4.

Operating System: Red Hat 8.1 Beta 4

Details:
Server (and Generation): All

Steps to reproduce:
1) Install Red Hat 8.1 Beta 4 (grub) 
2) Login to X server as root.
3) Start an xterm console window.
4) Output of attempting to run the command is:

[root@localhost root]# redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 48, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 180, in __init__
    self.datePage = date_gui.datePage(self.dateBackend)
  File "/usr/share/redhat-config-date/date_gui.py", line 171, in __init__
    ntpServer = socket.gethostbyaddr(ntpServerIP)[0]
TypeError: gethostbyaddr() argument 1 must be string, not None

Is the issue reproducible? yes 

Workaround: no
----------
Action by: Bryan.Leopard
Issue Registered

THIS IS ISSUE TRACKER 14891, OPENED AS SEV 3.

Comment 1 Bill Nottingham 2003-02-04 19:55:38 UTC

*** This bug has been marked as a duplicate of 82061 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:35 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.