Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83354 - (w/o XRENDER) Mozilla crash - join IRC channel
Summary: (w/o XRENDER) Mozilla crash - join IRC channel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-03 07:47 UTC by Warren Togami
Modified: 2007-04-18 16:50 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-22 01:09:51 UTC


Attachments (Terms of Use)
strace.out.bz2 (deleted)
2003-02-03 07:53 UTC, Warren Togami
no flags Details

Description Warren Togami 2003-02-03 07:47:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030130

Description of problem:
Make sure mozilla-chat is installed and go to this URL.
mozilla irc://irc.freenode.net/anychannel

If your X server lacks XRENDER, Mozilla crashes with the following message when
you join any IRC channel:
Gdk-ERROR **: BadValue (integer parameter out of range for operation)
 serial 11548 error_code 2 request_code 53 minor_code 0
Gdk-ERROR **: BadDrawable (invalid Pixmap or Window parameter)
 serial 11549 error_code 9 request_code 55 minor_code 0

I can reproduce this crash with Xvnc, Solaris 9 update 2 openwin, and X-Win32 5.0.

Version-Release number of selected component (if applicable):
mozilla-1.2.1-16

Comment 1 Warren Togami 2003-02-03 07:53:48 UTC
Created attachment 89797 [details]
strace.out.bz2

Complete strace.  Please let me know if you need any other debugging
information.

Comment 2 Christopher Blizzard 2003-02-03 18:27:50 UTC
-> XFree for render problems

Comment 3 Mike A. Harris 2003-02-04 00:41:52 UTC
Not sure I see the direct problem with X here..  could you elaborate
a bit please?

Comment 4 Warren Togami 2003-02-05 06:50:38 UTC
I just tested a Mozilla 1.2.1 build without Xft and it didn't crash in this test
case without XRENDER.

So would this indicate a bug in Mozilla, or Xft itself?

Comment 5 Mike A. Harris 2003-02-05 06:54:28 UTC
Reassigning to mozilla, but if it is fixed, it probably can be closed
as RAWHIDE.

Comment 6 Warren Togami 2003-02-22 01:09:51 UTC
This seems to be resolved by the same Xft bugfix that fixed Bug #80414.



Note You need to log in before you can comment on or make changes to this bug.