Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83353 - clock gui does not work
Summary: clock gui does not work
Keywords:
Status: CLOSED DUPLICATE of bug 76313
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-date
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-03 05:34 UTC by James Bunnell
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:34 UTC


Attachments (Terms of Use)
py (deleted)
2003-02-06 05:56 UTC, James Bunnell
no flags Details

Description James Bunnell 2003-02-03 05:34:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The clock on the desktop, when i right click on adjust date and time
and/or click on date and time in system settings, it prompts me for a
root password and then nothing happens. The time zone is way advanced
and i cannot seem to change it. any ideas?

The error returned below:


redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in
__init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in
setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.redhat-config-date in terminal
2.
3.
    

Actual Results:  Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in
__init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in
setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz

Expected Results:  opened the gui interface to adjust clock

Additional info:

Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in
__init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in
setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz

Comment 1 Brent Fox 2003-02-05 21:55:29 UTC

*** This bug has been marked as a duplicate of 76313 ***

Comment 2 James Bunnell 2003-02-05 22:27:00 UTC
how has this been resolved?

Comment 3 James Bunnell 2003-02-05 22:27:40 UTC
this does not appear as a duplicate. read that.

Comment 4 Brent Fox 2003-02-06 02:24:12 UTC
It *is* a dupe of #76313.  Take a look at some of the other dupes of bug #76313
and see that their traceback data is identical to yours:
bug #76164
bug #74206
bug #76707
etc. etc. etc.

You need to upgrade to the latest redhat-config-date from Rawhide, which is
redhat-config-date-1.5.9-4.  Reclosing.

*** This bug has been marked as a duplicate of 76313 ***

Comment 5 James Bunnell 2003-02-06 03:03:04 UTC
redhat-config-date
Traceback (most recent call last):
  File "/usr/share/redhat-config-date/redhat-config-date.py", line 35, in ?
    mainWindow.mainWindow().stand_alone()
  File "/usr/share/redhat-config-date/mainWindow.py", line 181, in __init__
    self.timezonePage = timezone_gui.timezonePage()
  File "/usr/share/redhat-config-date/timezone_gui.py", line 50, in __init__
    self.tz = TimezoneMap(zonetab, self.default, map=path)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 139, in __init__
    self.setCurrent(self.currentEntry)
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'


THIS IS AFTER I APPLIED THE REDHAT-CONFIG-DATE-1.5.9  !!!!!!!!!!!
this is not relevant to your dupe!

Comment 6 James Bunnell 2003-02-06 03:04:12 UTC
It will NOT open the GUI for adjusting the clock. 

Comment 7 Brent Fox 2003-02-06 03:39:01 UTC
What are the contents of /etc/sysconfig/clock?

Comment 8 James Bunnell 2003-02-06 04:31:20 UTC
ZONE="Etc/GMT-7"
UTC=false
ARC=false


Comment 9 Brent Fox 2003-02-06 05:10:18 UTC
Hmm...when I make my /etc/sysconfig/clock file look just like yours, the app
works  just fine.

Can you attach /usr/share/redhat-config-date/timezone_map_gui.py?

Comment 10 James Bunnell 2003-02-06 05:56:46 UTC
Created attachment 89880 [details]
py

here it is

Comment 11 Brent Fox 2003-02-06 14:55:01 UTC
Are you absolutely certain that you are running redhat-config-date-1.5.9-2 or
later?  Your /usr/share/redhat-config-date/timezone_map_gui.py is different than
it should be.  

Here's the difference between your file and the way it should look is in the
setCurrent function, which is where the traceback is occurring:

Your file:

def setCurrent(self, entry, skipList=0):
    if not entry:
        # If the value in /etc/sysconfig/clock is invalid, default to New York
        self.currentEntry = self.fallbackEntry

The way it should look:

def setCurrent(self, entry, skipList=0):
    if not entry:
        # If the value in /etc/sysconfig/clock is invalid, default to New York
        self.currentEntry = self.fallbackEntry
    else:
        self.currentEntry = entry


Cvs annotate shows that the last two lines were added by me on Oct 22, 2002: 

1.1          (bfox     31-Jan-02):     def setCurrent(self, entry, skipList=0):
1.6          (bfox     25-Jul-02):         if not entry:
1.6          (bfox     25-Jul-02):             # If the value in
/etc/sysconfig/clock is invalid, default to New York
1.6          (bfox     25-Jul-02):             self.currentEntry =
self.fallbackEntry
1.12         (bfox     22-Oct-02):         else:
1.12         (bfox     22-Oct-02):             self.currentEntry = entry

'cvs annotate timezone_map_gui.py' shows my entry on Oct. 22, 2002:
revision 1.12
date: 2002/10/22 15:16:01;  author: bfox;  state: Exp;  lines: +2 -1
fix bug 76313

Which backs up my earlier claim that the bug you are seeing is a duplicate of
bug #76313.  These two lines make sure that "self.currentEntry" is never "None",
which will avoid the traceback:
  File "/usr/share/redhat-config-date/timezone_map_gui.py", line 180, in setCurrent
    self.markers[self.currentEntry.tz].hide()
AttributeError: 'NoneType' object has no attribute 'tz'


'rpm -qi redhat-config-date-1.5.9-2.noarch.rpm' shows that the package was built
on Monday, Feb 2003:

[bfox@snowbird src]$ rpm -qip redhat-config-date-1.5.9-2.noarch.rpm
Name        : redhat-config-date           Relocations: (not relocateable)
Version     : 1.5.9                             Vendor: Red Hat, Inc.
Release     : 2                             Build Date: Mon 03 Feb 2003 01:45:49
PM EST


So I think that it's impossible for you to be running 1.5.9-2 and still be
seeing this bug since the timezone_map_gui.py file on your machine is from
before Oct. 22, 2002, which is months before the 1.5.9-2 package was even built.

Comment 12 James Bunnell 2003-02-06 16:15:52 UTC
Well, sorry to hear this. I updated the file you told me too via rawhide. I did
what you told me to do. What else can I do? All I want to be able to do is open
the GUI for adjusting and changing the clock. It works fine on my laptop. So
what is the problem? I dont understand. This is a Redhat problem and issue.

Comment 13 Brent Fox 2003-02-06 16:36:25 UTC
You can't really upgrade an individual file via Rawhide.  You have to upgrade
the entire redhat-config-date package and doing the upgrade will replace the
existing timezone_map_gui.py file with a newer one.  

Try this:
1) Download the latest redhat-config-date from Rawhide at
ftp://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/redhat-config-date-1.5.9-4.noarch.rpm

2) As root, run 'rpm -Uvh redhat-config-date-1.5.9-4.noarch.rpm'.  This should
upgrade all the files in redhat-config-date to the latest version.

3) Run 'redhat-config-date' and see if it works now.

Comment 14 James Bunnell 2003-02-06 17:10:48 UTC
Ahhh, it worked that way. I forgot the -Uvh the first time and just installed
it. Thank you very much. Sorry for my temper, it was just really annoying.

Comment 15 Brent Fox 2003-02-06 19:25:46 UTC
It's my fault.  I assumed that you knew what I meant by getting the latest
package from Rawhide.  I'm glad to know that things are working now.  Thanks for
your report.  

*** This bug has been marked as a duplicate of 76313 ***

Comment 16 Red Hat Bugzilla 2006-02-21 18:51:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.