Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83330 - system hangs after Finding module depencies [OK]
Summary: system hangs after Finding module depencies [OK]
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-02 18:26 UTC by Marius Andreiana
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-10 13:54:35 UTC


Attachments (Terms of Use)
/etc/fstab (deleted)
2003-02-02 18:28 UTC, Marius Andreiana
no flags Details
dmesg output (deleted)
2003-02-03 13:45 UTC, Marius Andreiana
no flags Details
Output of 'strace updfstab --skipprobe' (deleted)
2003-02-07 15:19 UTC, Miloš Komarčević
no flags Details

Description Marius Andreiana 2003-02-02 18:26:51 UTC
I have a CD-ROM and CD-RW on hda,hdb and an IDE hard drive on hde ( asus a7v
motherboard ). Sometimes I also plugin another IDE drive on hdf.

After upgrading to kudzu 0.99.91 the system will hang after 
Finding module depencies [OK]
is displayed ( next would have been checking filesystems ).

Booting from phoebe2 CD and selecting rescue will also hang the system after
displaying
hda: DMA disabled
hdb: DMA disabled

But everything works when I put the 2nd ide drive on hdf. When I installed
phoebe2 I didn't have this plugged in.  I'll attach /etc/fstab if it matters,
there's also a message with
Updating /etc/fstab... FAILED.

Comment 1 Marius Andreiana 2003-02-02 18:28:10 UTC
Created attachment 89783 [details]
/etc/fstab

Comment 2 Marius Andreiana 2003-02-03 13:45:13 UTC
Created attachment 89802 [details]
dmesg output

Comment 3 Bill Nottingham 2003-02-04 02:45:24 UTC
updfstab failing is fixed in .92.

Hanging after 'finding module dependencies' in rc.sysinit sounds like possibly a
kernel issue. If you enable sysrq, what does sysrq-t or sysrq-p show?

Comment 4 Miloš Komarčević 2003-02-04 18:36:24 UTC
I see fstab update failing on my machine 
even with kudzu-0.99.92-1 

Comment 5 Bill Nottingham 2003-02-04 20:10:09 UTC
What is the output of 'strace updfstab --skipprobe'?

Comment 6 Miloš Komarčević 2003-02-07 15:19:11 UTC
Created attachment 89926 [details]
Output of 'strace updfstab --skipprobe'

Comment 7 Bill Nottingham 2003-02-07 17:51:52 UTC
Hm, that looks *exactly* like the segfault fixed in .92, and I can't reproduce
it here.

Comment 8 Miloš Komarčević 2003-02-07 21:49:10 UTC
I see this on two machines out of three I run phoebe on.
The two have had a USB zip drive attached/removed if
that's of any help.

Comment 9 Bill Nottingham 2003-02-07 21:56:07 UTC
The crash or the hang?

Comment 10 Miloš Komarčević 2003-02-08 02:29:23 UTC
The updfstab segfault.
Should this be a separate bug for kudzu maybe?

Comment 11 Marius Andreiana 2003-02-10 13:54:35 UTC
after upgrading to kudzu .92, the fstab works for me ( also booting with only
the first hdd ).

I'm closing this, Milos please open another on kudzu if you still have problems
( mention this bug # as reference )


Note You need to log in before you can comment on or make changes to this bug.