Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83324 - Default httpd fails to start on kernel-2.4.18
Summary: Default httpd fails to start on kernel-2.4.18
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: httpd
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
: 82312 82635 83364 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-02 17:37 UTC by Alin Osan
Modified: 2007-04-18 16:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-11 19:39:45 UTC


Attachments (Terms of Use)

Description Alin Osan 2003-02-02 17:37:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030131

Description of problem:
When started, httpd fails with: [error] (38)Function not implemented: Cannot
create SSLMutex file `/etc/httpd/logs/ssl_mutex.18128'
Configuration Failed
After up-grade from 2.0.40-16 to 2.0.40-18 from rawhide fails with: [crit]
(38)Function not implemented: mod_rewrite: could not create rewrite_log_lock
Configuration Failed
After commenting out mod_rewrite from httpd.conf it fails with: 
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[emerg] (38)Function not implemented: Couldn't create accept lock
A friend of mine had same errors with 2.0.40-16 but after commenting out
mod_rewrite it started. But not for me.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. service httpd start (restart)
2.
3.
    

Actual Results:  httpd fails to start

Expected Results:  running httpd

Additional info:

When starter httpd fails with: [error] (38)Function not implemented: Cannot
create SSLMutex file `/etc/httpd/logs/ssl_mutex.18128'
Configuration Failed
After up-grade from 2.0.40-16 to 2.0.40-18 from rawhide fails with: [crit]
(38)Function not implemented: mod_rewrite: could not create rewrite_log_lock
Configuration Failed
After commenting out mod_rewrite it fails with: 
[notice] Digest: generating secret for digest authentication ...
[notice] Digest: done
[emerg] (38)Function not implemented: Couldn't create accept lock

Comment 1 Joe Orton 2003-02-03 10:30:09 UTC
What kernel are you using?

Comment 2 Ivo Sarak 2003-02-08 20:45:30 UTC
Same problem here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=83364

Comment 3 Joe Orton 2003-02-10 16:31:17 UTC
*** Bug 83364 has been marked as a duplicate of this bug. ***

Comment 4 Joe Orton 2003-02-10 16:33:04 UTC
Could you run "strace -o/tmp/trace /usr/sbin/httpd" and attach /tmp/trace?

Comment 5 Joe Orton 2003-02-10 16:58:48 UTC
Or don't bother - I've reproduced this, it happens when you boot the 2.4.18
kernel not the 2.4.20 kernel.

Comment 6 Joe Orton 2003-02-11 10:59:54 UTC
*** Bug 82312 has been marked as a duplicate of this bug. ***

Comment 7 Joe Orton 2003-02-11 11:57:28 UTC
Problem appears to be that Apache (APR) detects the working sem_open() in glibc
at build time (running on a .20 kernel), but sem_open() *only* appears to work
in the .20 kernel.

Comment 8 Joe Orton 2003-02-11 19:39:45 UTC
Many thanks for the reports.  This is fixed in httpd-2.0.40-20.

Comment 9 Joe Orton 2003-02-12 15:38:12 UTC
*** Bug 82635 has been marked as a duplicate of this bug. ***

Comment 10 Gerald Teschl 2003-02-12 16:47:06 UTC
Just for the records: I do run a 2.4.20 kernel! But anyway, 2.0.40-20 fixes
the problem for me.

Comment 11 Matthieu Godlewski 2003-04-21 00:01:58 UTC
This problem is unsolved with my 2.2.20 kernel and apache 2.0.45 ...

Comment 12 Joe Orton 2003-04-27 09:05:17 UTC
You may still run into this bug if you run a non-Red Hat-compiled httpd on a
non-Red Hat-kernel - but neither of these things are supported.

Comment 13 Bill Marrs 2003-07-17 11:55:19 UTC
I just wanted to mention that I ran into this problem when I built a 2.4.21 
kernel using Apache 2.0.47 (also built from source).  I made sure 
my /usr/include/linux was symlinked to /usr/src/linux/include/linux, rebuilt 
apache, and that fixed it for me.


Note You need to log in before you can comment on or make changes to this bug.