Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83309 - lpr can't map ip address to local printer
Summary: lpr can't map ip address to local printer
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-02 05:45 UTC by Jorge A. Aquino
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 16:50:27 UTC


Attachments (Terms of Use)

Description Jorge A. Aquino 2003-02-02 05:45:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
trying to print from a local epson stylus c60 printer. no response from computer
after print command (not even HD indicator! nada!) tried resetting driver (via
printconf) but could not print test page, or anything else, thereafter.

various diagnostics:

# 1


[root@littleman root]# lpr -v
Get_local_host: 'localhost' IP address not available!
[root@littleman root]#
[root@littleman root]#

* * *

#2

[root@bigboy root]# printconf

(printconf:1900): GLib-GObject-WARNING **: invalid cast from (NULL) pointer to
`GObject'

(printconf:1900): GLib-GObject-CRITICAL **: file gobject.c: line 972
(g_object_get): assertion `G_IS_OBJECT (object)' failed

(printconf:1900): GLib-GObject-WARNING **: invalid cast from (NULL) pointer to
`GObject'

(printconf:1900): GLib-GObject-CRITICAL **: file gobject.c: line 972
(g_object_get): assertion `G_IS_OBJECT (object)' failed
[root@bigboy root]#

* * *

3:

[root@bigboy root]# service lpd restart
Stopping lpd:                                              [FAILED]
Starting lpd: 2003-02-01-20:29:40.179 bigboy Get_local_host: 'localhost' IP
address not available!
                                                           [  OK  ]
[root@bigboy root]#

* * *

4: 

[root@bigboy root]# lpr
Get_local_host: 'localhost' IP address not available!
[root@bigboy root]#

* * *

hope that helps.



-ja


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.try to print from anywhere
2.nothing happens
3.various workarounds fail (see above)
    

Additional info:

Comment 1 Tim Waugh 2003-02-02 12:00:23 UTC
LPRng requires that you can resolve the host 'localhost' (to 127.0.0.1).  You
need to either add an entry to /etc/hosts, or sort it out with
redhat-config-network.

There should have been an appropriate entry in /etc/hosts already.  Did you
change /etc/hosts or /etc/resolv.conf after installing?

Comment 2 Jorge A. Aquino 2003-02-02 16:45:45 UTC
here's the rub: the "localhost" comes from the default installation host when I
installed RHL 8.0. I since changed the name to fit my machine onto a home
network. (New hostname is "littleman" on local domain "homespun".)

the program does not seem to have recognized that I changed the host/domain.

now i have gone back into /etc/hosts and added an entry:

     127.0.0.1	localhost.localdomain	local	loopback

but that does not seem to have changed anything. I am still getting that lpr
status message:

     [jaquino@littleman jaquino]$ lpr status
     Get_local_host: 'localhost' IP address not available!

And my /etc/resolv.conf entry is

     search localdomain
     nameserver 207.69.188.186
     nameserver 207.69.188.185

what am i doing wrong here? (thanks for the rapid response!)




-ja

Comment 3 Jeremy Katz 2003-02-03 16:50:27 UTC
You've changed /etc/hosts.  On the line with 127.0.0.1 in /etc/hosts, you *must*
leave "localhost.localdomain localhost"


Note You need to log in before you can comment on or make changes to this bug.