Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83300 - cp mv mkdir etc not statically linked
Summary: cp mv mkdir etc not statically linked
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: fileutils
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-01 23:19 UTC by bperkins
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-01 23:46:50 UTC


Attachments (Terms of Use)

Description bperkins 2003-02-01 23:19:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3a) Gecko/20021212

Description of problem:
IMHO there really isn't any good reason not to make these statically linked. 
This shouldn't be a problem under most circumstances, but can be a real
lifesaver (it would have saved me a lot of hassel).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.cd /
2.mkdir foo
3.mv lib foo
    

Actual Results:  Simple shell uutilities such as cp rm and mv don't work,
because the kernel can't find ld (lor libc for that matter).

Expected Results:  They should work.

Additional info:

Comment 1 Tim Waugh 2003-02-01 23:46:50 UTC
For rescue situations, use the rescue CD.  There's no reason to statically link
these binaries.


Note You need to log in before you can comment on or make changes to this bug.