Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83289 - 8.0.93 installer hangs w/out 'noapic'
Summary: 8.0.93 installer hangs w/out 'noapic'
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-02-01 16:58 UTC by Ian Pilcher
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-17 10:53:23 UTC


Attachments (Terms of Use)
output of 'lspci -vv' (deleted)
2003-02-01 17:00 UTC, Ian Pilcher
no flags Details

Description Ian Pilcher 2003-02-01 16:58:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
This is a regression from Red Hat 8.0 and the first public "Phoebe" beta.

I see hangs at various early points in the installation process, which I will
try to summarize below.

1)  Warm boot (from Red Hat 8.0) - Installer hangs after "running /sbin/loader"
appears on the console; blue screen never appears.  One of the consols says
something about waiting for USB to become sane.

2)  Cold boot, normal CD-ROM install - Installer hangs approximately 50% through
checking first CD; no error message anywhere.

3)  Cold boot, "linux askmethod" - Installer hangs as soon as method is
selected; "OK" button stays in "depressed" state.

None of these problems appear if 'noapic' is specified on the BOOT kernel
command line, amd the SMP kernel with APIC support appears to work fine once
installed.

This is an Abit VP6 with two 1 GHz Pentium III processors and 512 MB or memory.
 I will attach the output of 'lspci -vv'.  Let me know if you want anything else.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. See description.
2.
3.
    

Actual Results:  Installer hangs.

Expected Results:  Installer doesn't hang.

Additional info:

Comment 1 Ian Pilcher 2003-02-01 17:00:26 UTC
Created attachment 89765 [details]
output of 'lspci -vv'

Comment 2 Arjan van de Ven 2003-02-17 10:53:23 UTC
we've disabled apic support altogether now for the installer kernel, so this is
now fixed....


Comment 3 Ian Pilcher 2003-02-17 18:40:41 UTC
Works for me, but doesn't that have the potential to make installation
impossible on big servers with lots of PCI busses?


Note You need to log in before you can comment on or make changes to this bug.