Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83284 - (Mach64) Mouse cursor visual glitches with XFree86
Summary: (Mach64) Mouse cursor visual glitches with XFree86
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79578 82791
TreeView+ depends on / blocked
 
Reported: 2003-02-01 14:27 UTC by Felipe Alfaro Solana
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-16 16:35:34 UTC


Attachments (Terms of Use)
XF86Config (deleted)
2003-02-07 13:26 UTC, Felipe Alfaro Solana
no flags Details
sever log when using GATOS ATI.2 driver (deleted)
2003-02-07 15:15 UTC, Felipe Alfaro Solana
no flags Details

Description Felipe Alfaro Solana 2003-02-01 14:27:27 UTC
Description of problem:
-------------------------------
I have upgraded my Phoebe2 system to the latest XFree86 packages from RawHide
(they were XFree86-4.2.99-4.20030129 at that moment) and I have noticed some
visual glitches with my mouse cursor when it changes its shape. The visual
glitch is hard to describe: basically, when the mouse shape is changed (from an
arrow to the I-box, for example, or when you hover over a window resize handle),
for a very short period, the mouse is shown as a big 32x32 (I think) mess of
vertical lines of different thickness, and then, it returns to its normal
appearance.

It doesn't seem a driver problem, since in XFree86-4.2.99.3-20030115.0 this
problem is not present. Also, this is mainly a visual problem since the mouse
cursor is drawn incorrectly for a few microseconds.

My video card is an ATI Rage Mobility M1 AGP 8MB using the Gatos SourceForge ATI
4.2.0 and 4.3.0 (experimental) video driver with XV support.

I have had to downgrade to XFree86-4.2.99.3-20030115.0 since this visual effect
is disgusting for me.

Version-Release number of selected component (if applicable):
----------------------------------------------------------------------------------
XFree86-4.2.99-4.20030129

How reproducible:
------------------------
Always

Steps to Reproduce:
---------------------------
1. Install Phoebe2 onto a computer with an ATI Rage Mobility M! (or Mach64)
video card or similar.
2. Upgrade to XFree86-4.2.99-4.20030129 from RawHide
3. Get the Gatos ATI.2 video driver from http://gatos.sourceforge.net and
install it.
4. Launch X
5. Make the cursor shape change by hovering the mouse cursor over a window
resize handle, for example. Sometimes, the visual glitch described is shown.
    
Actual results:
--------------------
The mouse cursor looks strange during transition of mouse cursor shape.

Expected results:
-----------------------
Mouse cursor should always be drawn correctly, as in previous versions of XFree86

Additional info:
---------------------
Phoebe2 clean install doesn't exhibit this hehaviour. However, upgrading to a
newer XFree86 version using up2date, or manually from RawHide, makes this show.
It seems a problem with new mouse cursor handling, as mouse cursors also look
different in RawHide (for example, Mozilla uses a combined arrow-hourglass mouse
cursor while downloading Web pages).

Comment 1 Felipe Alfaro Solana 2003-02-02 19:16:24 UTC

*** This bug has been marked as a duplicate of 82997 ***

Comment 2 Mike A. Harris 2003-02-03 05:36:35 UTC
This bug is _NOT_ a duplicate of 82997.  Bug 82997 is broken hardware
mouse cursor code on SiS chipsets.  This bug is Radeon hardware cursor
is affected by Xcursor code changes.  2 separate issues.

Comment 3 Mike A. Harris 2003-02-03 05:52:14 UTC
I just noticed that you are using the GATOS drivers.  Red Hat obviously
does not ship GATOS drivers and is not responsible for problems encountered
while using the GATOS drivers.

However, the XFree86 driver which is supplied in rawhide also has this
mouse cursor problem.   Please however do not file bug reports against
XFree86 if you're using GATOS drivers or drivers from anywhere else than
what is supplied by Red Hat, unless you can reproduce it with Red Hat
supplied drivers after a fresh reboot (to hardware reset the card to power
on defaults).

I'm leaving this open as I know our drivers also have this problem.  There
is a fix or workaround just about ready for testing, but of course you'll
have to use the Red Hat supplied driver in order to test it.  The GATOS
author might be interested in it though as well if it works out, so once
I'm sure it works, I will contact him too, so he can fix the GATOS driver
as well.

Comment 4 Felipe Alfaro Solana 2003-02-03 12:58:35 UTC
When I reported this bug, I didn't said I had an ATI Radeon video card, but a
Mach64-based ATI RAGE Mobility M1 AGP...

So, I don't understand why Radeon keyword has been added to the summary :-?

Comment 5 Mike A. Harris 2003-02-06 02:35:02 UTC
Oops... because I'm dumb.  ;o)

Comment 6 Mike A. Harris 2003-02-07 10:15:45 UTC
Please attach your X server log and config file.

Comment 7 Felipe Alfaro Solana 2003-02-07 13:26:14 UTC
Created attachment 89923 [details]
XF86Config

This is my XF86Config file... It's the same no matter whether I'm using the
stock XFree86 ATI Mach64 driver or the GATOS video driver (the GATOS video
driver replaces the ati_drv.o module so no changes to XFree are needed).

Comment 8 Felipe Alfaro Solana 2003-02-07 13:29:11 UTC
I can' currently supply the XFree86 server log as I have downgraded to the
original XFree86 package that came with Phoebe2, and not using the one from
RawHide. If you don't mind, I prefer to wait for a new release of the GATOS
ATI.2 video driver (which will be released soon AFAIK) and then try to reproduce
with the latest XFree86 release at the moment (RawHide).

Comment 9 Mike A. Harris 2003-02-07 13:51:54 UTC
No problem.  That just means this is more unlikely to get fixed
for 4.3.0.  ;o)

Comment 10 Felipe Alfaro Solana 2003-02-07 15:13:57 UTC
I'm still experiencing this behavior with XFree86-4.2.99.901-20030203.1 using
both stock ATI driver and GATOS ATI.2 (4.3.0 experimental 4) driver. I will
attach my X server log.

Comment 11 Felipe Alfaro Solana 2003-02-07 15:15:11 UTC
Created attachment 89925 [details]
sever log when using GATOS ATI.2 driver

Comment 12 Felipe Alfaro Solana 2003-02-08 14:35:42 UTC
Curiously, when using Rawhide's XFree86-4.2.99.901-20030205, it seems the mouse
cursor visual glitch does not happen when changing from a certain cursor shape
to another: for example, when changing from the standard black pointer arrow to
Mozilla's new hand shape that is shown when the mouse hovers over a link, I'm
unable to reproduce the visual glitch. It seems the transition is smooth and no
strange artifacts are drawn on the screen (at least, I can't appreciate them).

However, when the mouse shape changes between the black pointer arrow and the
I-box cursor (the one that is shown when the mouse is over most text edit
controls) or the window resize cursor (north-south or west-east), the visual
glitch can still be seen.

Comment 13 Felipe Alfaro Solana 2003-02-09 16:09:37 UTC
I'm also able to reproduce the mouse cursor visual glitch when using stock
XFree86 ATI video driver. I removed the GATOS video driver, then upgraded to
XFree86-4.2.99.901-20030206.0. However, I still have the mouse cursor
problem,easily reproducible by forcing a mouse cursor shape transition between
I-beam (or whatever you call the mouse cursor displayed on text controls) and
the standard arrow.

Comment 14 Mike A. Harris 2003-02-14 06:01:03 UTC
A bugfix for this has been committed to XFree86 CVS.  I am updating my
sources, and will be releasing a new build within 12 hours.

Comment 15 Felipe Alfaro Solana 2003-02-15 02:35:42 UTC
I'm still experiencing this issue with XFree86-4.2.99.901-20030212.

Comment 16 Mike A. Harris 2003-02-15 14:58:28 UTC
sorry, my build was completed in 12 hours, but didn't get anywhere public
in 12 hours.

XFree86-4.2.99.901-20030213.1 should fix this.  It's at:

ftp://people.redhat.com/mharris/testing/unstable

Please test and resolve bug as RAWHIDE or ASSIGNED.

Comment 17 Felipe Alfaro Solana 2003-02-16 16:35:34 UTC
OK, your XFree86-4.2.99.901-20030213.1 package fixed this for me.
I'm closing this bug as fixed in RawHide right now. Thanks!


Note You need to log in before you can comment on or make changes to this bug.