Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83231 - install hangs on SMP system
Summary: install hangs on SMP system
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 9
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-31 16:26 UTC by Gene Czarcinski
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-11 15:32:32 UTC


Attachments (Terms of Use)

Description Gene Czarcinski 2003-01-31 16:26:07 UTC
Description of problem:
I have two SMP systems where the install hangs (both gui and text).  I have
tried local cdrom, hard drive, and nfs installs.  Both of these systems have
successfully installed 8.0.92.  The install hangs are various places but usually
when it is starting X.

I suspect that the problem is really a kernel problem but it happens at various
places during install.

The cdroms have been mediachecked OK and successfully used to install on non-smp
systems.

Version-Release number of selected component (if applicable):
8.0.93

One system is a dual PIII (933MHz) with 900MB ram and ATI 7500 video.  The other
is a dual PII (400MHz) with 300MB ram and ATI Rage video.

Both successfully install and run  8.0 and 8.0.92.

How reproducible:
always

Comment 1 Michael Fulbright 2003-01-31 17:34:14 UTC
Anything obviously wrong printed out on any VCs?

Does sysreq tell you anything?


Comment 2 Gene Czarcinski 2003-01-31 18:24:53 UTC
I just ran a test on one of the systems.  I found on VC4 messages saying

  hdd  lost interrupt

multiple times.  hdd is the cdrom drive.  I will check the other system in a
couple of minutes.  Strange that this occurs only with SMP systems.  I also
tried using "linux ide=nodma askmethod" and it hung as soon as it tried to get
to the cdrom.

BTW, I believe the Red Hat mailing list servers are constipated again.

Comment 3 Gene Czarcinski 2003-01-31 18:58:38 UTC
OK, similar thing on the second (dual P-III) system.  Two happenings:

1. Did "linux ide=nodma askmethod" and then selected local cdrom.  This hung
solid  (freeze) when it got the first X screen up with the mouse.  I could do
nothing ... could not switch to VCs.

2. Did "linux ide=nodma askmethod text" and then again selected Local cdrom. 
This got further -- to actual install.  While formating "/" (only one partition
5GB partition defined), it hung about 75% into formatting.  Checking VC4, I found:

Lots of messages saying
  <6>ide:  no cache flush required

and finally:

<3>hdb:  lost interrupt

hdb is the drive containing the "/" partition.

BTW, this system (and the other one) both have 8.0 and 8.0.92 installed and running.

Comment 4 Gene Czarcinski 2003-02-01 18:57:48 UTC
OK, I am changing this to the kernel component.  Thanks to Smooge, the problem
appears to be released to APIC.  I booted the cdrom with "linux noapic" and
successfully installed and ran 8.0.93.

I am ading arjanv to the cc list since that seems to be who get assigned kernel
stuff.  Please adjust the cc list as appropriate or make this a dup of something
that I missed in my searches.

Comment 5 Arjan van de Ven 2003-02-02 10:00:19 UTC
the apic stuff has been removed since a few days; that should fix this too.

Comment 6 Gene Czarcinski 2003-02-02 11:15:53 UTC
I hope just from the install (BOOT) kernel since it seems to work fine when I am
running the smp kernel.

I have not tested it yet but how about the regular non-smp kernel.  Would
running it with APIC enabled screw things up?  If so then maybe it should only
be enabled for the smp kernel.

You comment about APIC being removed a few days ago.  I have not tried one of
the more recent kernels but it is enabled for the 2.4.20-2.24 smp kernel (the
one that does not have the shutdown problem).

Comment 7 Arjan van de Ven 2003-02-02 11:20:27 UTC
yes I meant the BOOT kernel. SMP kernel of course still has apic (no SMP system
without apics exist).

It's removed in -2.27 or so.. -2.30 has the reboot problem fixed fwiw


Note You need to log in before you can comment on or make changes to this bug.