Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83206 - Incorrect test of return code from grep command in /etc/rc.d/rc.sysinit
Summary: Incorrect test of return code from grep command in /etc/rc.d/rc.sysinit
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-31 09:10 UTC by Need Real Name
Modified: 2014-03-17 02:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-31 17:08:19 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:341 normal SHIPPED_LIVE New initscripts packages available 2003-12-19 05:00:00 UTC

Description Need Real Name 2003-01-31 09:10:44 UTC
Description of problem:
The conditional expression beginning at line 302 of /etc/rc.d/rc.sysinit has a
middle expression ("$_ROOT_HAS_QUOTA") that will always test true, no matter
what the return code is of the preceding grep|awk|grep pipeline. This is because
"$_ROOT_HAS_QUOTA" will always be a non-null string.

Version-Release number of selected component (if applicable):
initscripts-6.67-1

How reproducible:
N/A

Steps to Reproduce:
1.
2.
3.
    
Actual results:
"$_ROOT_HAS_QUOTA" always tests true.

Expected results:
"$_ROOT_HAS_QUOTA" only tests true if the quota option is given for the root
filesystem in /etc/fstab.

Additional info:
Suggest that the test is altered to:

... -a "$_ROOT_HAS_QUOTA" = "0" ...

Comment 1 Bill Nottingham 2003-01-31 17:08:19 UTC
Fixed, will be in 7.06-1.

Comment 2 John Flanagan 2003-12-19 19:13:48 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-341.html



Note You need to log in before you can comment on or make changes to this bug.