Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83204 - redirect stopped working
Summary: redirect stopped working
Keywords:
Status: CLOSED DUPLICATE of bug 78903
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinetd
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Brock Organ
URL:
Whiteboard:
: 83205 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-31 08:12 UTC by Robert de Bock
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:31 UTC


Attachments (Terms of Use)

Description Robert de Bock 2003-01-31 08:12:18 UTC
From Bugzilla Helper:
User-Agent: Opera/6.11 (Linux 2.4.18-10 i686; U)  [en]

Description of problem:
Redirects worked in version 2.3.4-0.8 of xinetd, but stopped working since version 2..7-4.7x (up2date).
The configuration used is the same, just the software changed. Here is a sample configuration:
/etc/xinetd.d/smtp
---
service smtp
{
        flags           = REUSE
        socket_type     = stream        
        wait            = no
        log_on_failure  += USERID
        disable         = no
        user            = root
        redirect        = 192.168.0.2 25
}
---
Here is a small piece of log:
---
Jan 31 08:21:55 gw xinetd[3078]: xinetd Version 2.3.7 started with libwrap options compiled in.
Jan 31 08:21:55 gw xinetd[3078]: Started working: 0 available services
Jan 31 08:21:58 gw xinetd: xinetd startup succeeded
---

As a workaround you could setup ssh to do port-redirection.

Someone already found this identical problem:
https://listman.redhat.com/pipermail/psyche-list/2002-December/008320.html

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install the new version of xinetd, using up2date or whatever tool.
2. restart xinetd and watch your logs or test the redirects.
   

Actual Results:  xinetd stopped redirecting.

Expected Results:  xinetd should redirect.

Additional info:

Comment 1 Robert de Bock 2003-01-31 08:16:30 UTC
*** Bug 83205 has been marked as a duplicate of this bug. ***

Comment 2 Robert de Bock 2003-02-03 10:49:19 UTC

*** This bug has been marked as a duplicate of 78903 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.