Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83177 - Vim spinning doing SEGV's
Summary: Vim spinning doing SEGV's
Keywords:
Status: CLOSED DUPLICATE of bug 83700
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vim
Version: 7.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-31 01:24 UTC by Emmanuel Galanos
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:31 UTC


Attachments (Terms of Use)

Description Emmanuel Galanos 2003-01-31 01:24:36 UTC
Description of problem:
On a Red Hat 7.0 box, after installing the latest Vim errata, there
are vim processes (from vim-enhanced package) lying around occasionaly
after a user logs out. They are in a loop spinning taking up as much CPU
as they can get. An ltrace -i -p shows:

[400a74b0] --- SIGSEGV (Segmentation fault) ---
[400a74b0] --- SIGSEGV (Segmentation fault) ---
[400a74b0] --- SIGSEGV (Segmentation fault) ---

/proc/$PID/maps shows this as being in:

4009d000-400ac000 r-xp 0000000000000000 09:01 394029     /lib/libpthread-0.9.so

Not sure if this is a vim bug or a glibc bug.

Version-Release number of selected component (if applicable):
vim-common-6.1-18.7x.2
vim-minimal-6.1-18.7x.2
vim-enhanced-6.1-18.7x.2
glibc-2.2.4-18.7.0.8 (i686)

How reproducible:
100 %

Steps to Reproduce:
1. ssh machine
2. vim
3. insert mode then type some crap in.
4. use ssh escape codes to exit
<LF>
~
.
    
Actual results:
SEGV spin.

Expected results:
process to exit.

Comment 1 Karsten Hopp 2003-06-20 11:50:05 UTC

*** This bug has been marked as a duplicate of 83700 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:31 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.