Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83160 - cut, copy non-functional with RMB _within_ a document (RH.8.0.9.3)
Summary: cut, copy non-functional with RMB _within_ a document (RH.8.0.9.3)
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gedit
Version: phoebe
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-30 20:46 UTC by Elton Woo
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-31 23:26:44 UTC


Attachments (Terms of Use)

Description Elton Woo 2003-01-30 20:46:42 UTC
Description of problem:
Placing the RMB _within a document_, I can only cut or paste from the 
Gedit menu, NOT with the mouse. undo, and redo function with the
mouse within the document. 

Version-Release number of selected component (if applicable):

]$ rpm -q gedit
gedit-2.1.4-1

How reproducible:

Steps to Reproduce:
1. Open a document from Gnome with Gedit, or open Gedit and select a new document
2.  Highlight text to be cut or pasted with the right mouse button.
3. Try to cut or paste highlighted text.
    
Actual results:
Options are greyed out (unavaialable)
These actions are only available from the gedit menu.

Expected results:

Options for cut / paste should be available once text is marked.
Additional info:

Hardware: Logitech USB Optical Mouse connected via 4-port USB hub.

Comment 1 Havoc Pennington 2003-01-30 21:28:20 UTC
I am not parsing what you mean here. You mean on the right-click menu, 
the cut/paste options are not enabled?

Comment 2 Michael Knepher 2003-01-31 23:00:34 UTC
Here's the behavior I'm seeing - if you highlight a section of text, and
right-click *outside* of the highlighted area or an a highlighted line that has
no text on it (i.e., only a line-break where the highlighting spans the width of
the editing window), it basically de-selects the text, thus disabling the copy
and cut items on the context. Right-clicking *inside* the highlighted area on a
line with text will retain the selection and enable the copy and cut items on
the context menu.



Comment 3 Elton Woo 2003-01-31 23:15:45 UTC
Michael  Knepher seems to have put his finger on it. I guess once the pointer
gets _just outside_
the highlighted text, I lose the ability to copy / cut. Since I'm running the
screen at 1024 x 768, it's pretty easy to RMB just after (i.e. *outside of*) the
selected text. Not only that, but once
I highlight my text, doing a right mouse click actually "deselects'  the text.
(The text is no longer 
highlighted.

I'm reasonably certain that I didn't see this behavoir in Phobe1. e.g. In
Mozilla, or even in
nautilus, I can let my RMB click on white space, and I *still* get the cut /
copy option. Whereas,
with gedit, I have to remember to _keep the mouse pointer within_ the selected text.

The crux of the problem here is the pointer MUST remain _*somewhere* within_ the
selected text.

Comment 4 Havoc Pennington 2003-01-31 23:26:44 UTC
OK, thanks. I've reported this as
http://bugzilla.gnome.org/show_bug.cgi?id=104950

Comment 5 Michael Knepher 2003-01-31 23:53:22 UTC
I'm not sure if this affects the same component, but the same thing occurs in
evolution-1.2.1. I haven't checked any other apps yet.


Note You need to log in before you can comment on or make changes to this bug.