Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83158 - rhn-applet-gui requires network to be up before it's started
Summary: rhn-applet-gui requires network to be up before it's started
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-30 20:42 UTC by Andre Robatino
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-03 21:31:57 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:080 normal SHIPPED_LIVE Updated RHN Notification Tool available 2003-04-09 04:00:00 UTC

Description Andre Robatino 2003-01-30 20:42:53 UTC
Description of problem:
  If the network is down when rhn-applet-gui is started, then "Check for
updates" will fail even if the network is subsequently brought up.  For example,
this situation holds if one is on dialup and brings up the network manually
after logging in (when rhn-applet-gui is automatically started).  The only
workaround I'm aware of is to bring up the network, then kill rhn-applet-gui,
then restart it.  My father and I both have the same problem.  I have DSL and
can avoid it by bringing up the network at boot time.  He's on dialup and this
isn't practical, so I advised him to put the appropriate commands in the
modemlights startup.

Version-Release number of selected component (if applicable):
2.0.0-28

How reproducible:
always

Steps to Reproduce:
1.  Bring down the network, if it's up.
2.  Login in X windows, causing rhn-applet-gui to start up.  It will gray out,
of course.
3.  Bring up the network.
4.  Get rid of the network error message by left-clicking on the RHN applet and
dismissing it.  Then right-click on the RHN applet and select "Check for updates".
 
Actual results:
  It turns green, then goes gray.  It can never work unless it's killed and
restarted _after_ the network connection is up. 

Expected results:
  It should turn green, then turn either blue or red depending on whether there
are updates.

Additional info:

Comment 1 Tom Mortell 2003-02-02 02:32:15 UTC
I can confirm that this also occurs with rhn-applet-2.0.7-2
Every two minutes it will access the disk while green and
then go gray with a red slash.

If rhn-applet is started while on-line,
green turns to blue with white check mark.
"No updates available..."

Tom Mortell

Comment 2 Daniel Veillard 2003-02-03 21:31:57 UTC
I can't reproduce this with the version in RawHide.
As long as the network won't be up, the icon will 
be the grey and red one indicating the absence of 
connection to the server but once the ethernet card
is plugged in the laptop then the connection succeed
and indicate the current status sucessfully within
a couple of minutes.

  Works for me,

Daniel

Comment 3 Andre Robatino 2003-02-03 21:55:19 UTC
  I installed RawHide version 2.0.7-2 in a basically 8.0 installation but it
segfaults when I try to run it.  Presumably the whole fix depends on having the
latest version of other packages as well.  It's important that this work in 8.1,
otherwise anyone on dialup is screwed (though I know that Red Hat isn't
targeting the home user quite yet!).

Comment 4 Daniel Veillard 2003-02-03 22:18:35 UTC
Yes it is expected to be fixed in the next release of Red Hat Linux.

Daniel

Comment 5 Chip Turner 2003-04-09 16:35:14 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-080.html


Comment 6 Tom Mortell 2003-04-11 00:36:47 UTC
The problem is still there, for me, after updating to
rhn-applet-2.0.9-0.8.0.1.i386.rpm
as noted in errata RHBA-2003-080

Tom Mortell

Comment 7 Tom Mortell 2003-12-16 19:22:26 UTC
The problem is gone in Fedora Core 1 with 
rhn-applet 2.1.4-3

Tom Mortell


Note You need to log in before you can comment on or make changes to this bug.