Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83136 - Mousedriver causes X to hang
Summary: Mousedriver causes X to hang
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
: 82835 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-30 17:26 UTC by Enrico Scholz
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-17 00:02:14 UTC


Attachments (Terms of Use)
/etc/X11/XF86Config-4 (deleted)
2003-01-30 17:28 UTC, Enrico Scholz
no flags Details
/var/log/XFree86.0.log (deleted)
2003-01-30 17:35 UTC, Enrico Scholz
no flags Details

Description Enrico Scholz 2003-01-30 17:26:55 UTC
Description of problem:

When starting the recent rawhide XFree86, it hangs before showing anything.
Investigations show that /usr/X11R6/lib/modules/input/mouse_drv.o is the
responsible part; when using the module from XFree86-4.2.99.3-20030115.0, things
are fine.

A speciality of my system is, that 'gpm' is used in repeater-mode (the laptop
locks the keyboard randomly on unhandled mouse-input, so I am using gpm which
keeps the FIFO empty):

| $ ps x
| /usr/sbin/gpm -m /dev/misc/psaux -tps2 -Rps2



Version-Release number of selected component (if applicable):

XFree86-4.2.99.4-20030121.6
gpm-1.20.0-2
vanilla linux-2.4.20 kernel
dev-filesystem


XFree86-4.2.99.3-20030115.0 works fine

Comment 1 Enrico Scholz 2003-01-30 17:28:19 UTC
Created attachment 89718 [details]
/etc/X11/XF86Config-4

Comment 2 Enrico Scholz 2003-01-30 17:34:38 UTC
Some additional information about the hanging X:

# lsof -p `pidof X`
COMMAND PID USER   FD   TYPE     DEVICE     SIZE    NODE NAME
...
X       810 root    7u  FIFO        0,6              421 /dev/gpmdata

# strace -p `pidof X`
select(1024, [7], NULL, NULL, {0, 200000}) = 1 (in [7], left {0, 200000})
read(7, "\354", 1)                      = 1
write(7, "\354", 1)                     = 1
nanosleep({0, 10000000}, NULL)          = 0
select(1024, [7], NULL, NULL, {0, 200000}) = 1 (in [7], left {0, 200000})
read(7, "\354", 1)                      = 1
write(7, "\354", 1)                     = 1
nanosleep({0, 10000000}, NULL)          = 0
select(1024, [7], NULL, NULL, {0, 200000}) = 1 (in [7], left {0, 200000})
read(7, "\354", 1)                      = 1
write(7, "\354", 1)                     = 1
nanosleep({0, 10000000}, NULL)          = 0
...


Comment 3 Enrico Scholz 2003-01-30 17:35:37 UTC
Created attachment 89719 [details]
/var/log/XFree86.0.log

Comment 4 Enrico Scholz 2003-01-30 17:42:53 UTC
When using the working mouse_drv.o from XFree86-4.2.99.3, the log-file continues
with:

---
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
(II) Mouse0: ps2EnableDataReporting: failed
---

Comment 5 Sammy 2003-01-31 19:08:40 UTC
*** Bug 82835 has been marked as a duplicate of this bug. ***

Comment 6 Sammy 2003-02-27 15:08:49 UTC
Unfortunately, just tested the XFree86-4.2.99.902-20030224.1 with my DELL Inspiron and 
the system still hangs with a frozen mouse. The log file is similar to the one mentioned above. 
I did not get a chance to test 4.3.0-1 but probably the same. The culprit is probably the new 
dynamic ps/2 mouse driver. 

Comment 7 Mike A. Harris 2003-04-11 10:33:10 UTC
Does this problem still occur on a Red Hat Linux 9 clean installation?


Comment 8 Sammy 2003-04-16 16:13:08 UTC
No. Things are working with 9 and beyond. 

Comment 9 Mike A. Harris 2003-04-16 23:06:03 UTC
Enrico?

Comment 10 Enrico Scholz 2003-04-17 00:02:14 UTC
Currently I do not have a clean RHL 9 installation but a rawhide-based one with
gpm-1.20.1. This setup hanged on 2003-01-30 and works fine now.

I do not see the problem after downgrading to the shipped gpm-1.19.3 also, but
this downgrade required a lot of significant changes and is not the same setup
as before.

Closing the bug...

Comment 11 Mike A. Harris 2003-04-17 00:21:11 UTC
Ok, thanks a bunch for the update!


Note You need to log in before you can comment on or make changes to this bug.