Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8313 - rsh-server-0.16-3.i386.rpm in.rshd fails to exit
Summary: rsh-server-0.16-3.i386.rpm in.rshd fails to exit
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rsh
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-09 21:07 UTC by dunwoody
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-10 18:58:26 UTC


Attachments (Terms of Use)

Description dunwoody 2000-01-09 21:07:26 UTC
Perhaps there's a change that I'm unaware of, or my system's misconfigured,
but after I installed rsh-server-0.16-3.i386.rpm, I find that rsh still
works, but in.rshd on the remote system fails to exit.  The child process
of in.rshd (the executed command) stays around in unkillable sleep, untill
I killall in.rshd.

When I try "rsh dunwoody1 date", I see the following in dunwoody1's
/var/log/messages:

    Jan  9 13:00:10 dunwoody1 in.rshd[3290]: connect from
c130441-k.smateo1.sfba.home.com

The "date" command executes successfully, then a "ps" on dunwoody1 shows:

 3290 S  0.3  0.6 in.rshd -h
 3291 Z  0.4  0.0 [date <defunct>]

I'm running all the latest RawHide rpm's as of 2000/01/09 1200PST,
including kernel-2.2.14-1.1.0.  If you can't reproduce this (I hope you
can), I'd be happy to provide more details.

Comment 1 Jeff Johnson 2000-01-10 16:58:59 UTC
I've reproduced this problem, will have a fix shortly. Use the rsh-0.10
package from 6.1 if you need a fix Right Now.

Comment 2 Jeff Johnson 2000-01-10 18:58:59 UTC
Fixed in rsh-0.16-4. Thanks for noticing.


Note You need to log in before you can comment on or make changes to this bug.