Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83122 - rpm -V fileutils won't detect missing files
Summary: rpm -V fileutils won't detect missing files
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-30 15:25 UTC by Peter Åstrand
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-31 17:07:57 UTC


Attachments (Terms of Use)

Description Peter Åstrand 2003-01-30 15:25:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc1) Gecko/20020417

Description of problem:
I've been trying to research why Swedish LC_MESSAGES don't work on a certain
system. I found out that /usr/share/locale/sv/LC_MESSAGES/fileutils.mo was
missing, but rpm -V fileutils didn't detect this:

[root@bornholm root]# ls /usr/share/locale/sv/LC_MESSAGES/fileutils.mo
ls: /usr/share/locale/sv/LC_MESSAGES/fileutils.mo: No such file or directory
[root@bornholm root]# rpm -V fileutils
[root@bornholm root]#

Still, the RPM db thinks that the fileutils pkg owns this file:

[root@bornholm root]# rpm -qf /usr/share/locale/sv/LC_MESSAGES/fileutils.mo
fileutils-4.1.9-11

After re-installing fileutils with --force, things work correctly:

[root@bornholm root]# rm /usr/share/locale/sv/LC_MESSAGES/fileutils.mo
[root@bornholm root]# rpm -V fileutils
missing    /usr/share/locale/sv/LC_MESSAGES/fileutils.mo


Version-Release number of selected component (if applicable):
rpm-4.1-1.06

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
I guess this can be reproduced by installing a new system and *not* choosing to
include support for Swedish, but I haven't tried.

Comment 1 Jeff Johnson 2003-01-31 17:07:57 UTC
My guess is that the file isn't missing, it was not
installed.

Look at "rpm -qs fileutils" output to find the install state of
the file in question.

Reinstall the package with a different setting for

#       A colon separated list of desired locales to be installed;
#       "all" means install all locale specific files.
#
%_install_langs all

If using rpm, just reinstall the package.

If using anaconda, this can be done by selecting what locales
you are interested in.

Please reopen if the above is not the problem.


Note You need to log in before you can comment on or make changes to this bug.