Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83101 - VTE does not implement xterm mouse support fully
Summary: VTE does not implement xterm mouse support fully
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: vte
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-30 08:13 UTC by D. Hugh Redelmeier
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-11-10 20:43:01 UTC


Attachments (Terms of Use)

Description D. Hugh Redelmeier 2003-01-30 08:13:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
xterm has features to allow text-based programs to respond to mouse events. 
They are documented in section "Mouse Tracking" of
/usr/share/doc/XFree86-doc-4.2.0/xterm/ctlseqs.PS.gz

VTE seems to implement "Normal tracking mode" (used by PINE, for example) but
not "Mouse hilite tracking" (used by JOVE, for example).

Either gnome-terminal ought to not advertise itself as "xterm" in the TERM
variable, or it ought to implement the capability.  Since it just uses VTE, this
means VTE ought to implement this capability.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.install JOVE:
  wget -N ftp://ftp.cs.toronto.edu:/pub/hugh/jove-dev/jove4.16.0.58.tgz
  rpmbuild -ta jove4.16.0.58.tgz
  rpm -i /usr/src/redhat/RPMS/i386/jove*.rpm
(Could adjust procedure to not require su).
2.get into jove on some random file: jove .profile
3.try to move with the mouse (failure)
4.leave JOVE: ^X^C
    

Actual Results:  JOVE does not respond to mouse

Expected Results:  JOVE responds to mouse.  Works on real xterm.

Additional info:

Comment 1 Ray Strode [halfline] 2004-11-10 20:43:01 UTC
Thanks for the bug report.  At the moment, the Fedora developers don't have
time to work on this particular issue. The best way to make sure your problem
will get looked on is to report it to the authors of the program. Most 
upstream authors use a bug tracking system like bugzilla, and more people
who know the code will be looking at the bug report there.

The upstream bug tracking system to use is:
http://bugzilla.gnome.org

Please make sure the bug isn't already in the upstream bug tracker before
filing it.


Note You need to log in before you can comment on or make changes to this bug.