Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83069 - No device data for compaq smart card 5304
Summary: No device data for compaq smart card 5304
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Baron
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 22:37 UTC by Need Real Name
Modified: 2013-03-06 05:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-01-06 15:32:25 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-29 22:37:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Statistics for a Compaq smart card 5304 is not being collected. When I cat
/proc/stat I do not have info after "disk io:"

The card shows up as device /dev/cciss/c0d0 and is in /proc/partitions, but
still shows up as blank under iostat (I can explicitly specify the device). isag
also has no stats to graph.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Type iostat

    

Actual Results:  No devices show up under device, as well as no data. Cpu is there.

Expected Results:  Data

Additional info:

Comment 1 masanari iida 2003-07-22 11:00:38 UTC
specify "-x devicefile" will help. 
(ex)  iostat -x /dev/cciss/c0d0

Comment 2 Charlie Bennett 2004-09-23 19:24:15 UTC
This looks like a dup of the iostat cciss bug report against RHEL3.

The driver is not reporting in /proc.



Comment 4 Tom Coughlan 2004-11-01 18:09:00 UTC
Charlie,

If I understand the situation correctly, this can not be fixed in the
driver because upstream vetoed that approach.  As a result, you put a
workaround in iostat for RHEL 3.  

We don't necessarily need to go that far out of our way for this in AS
2.1, but I don't know all the pros/cons. What do you think?

Tom

Comment 5 Charlie Bennett 2004-11-01 22:11:10 UTC
Hi Tom -  there's a partial workaround (device major 104 only) in
U4/U4.  There's a full-blown solution being tested by JohnRay Fuller
at a number of customer sites.

Jared: does this fix you up?

http://people.redhat.com/ccb/sysstat/2.1AS/5.0.5-10.21as

Comment 6 Need Real Name 2004-11-16 21:47:43 UTC
Yes upgrading to the lastest sysstat rpm did the trick.

Thanks,

Jared


Note You need to log in before you can comment on or make changes to this bug.