Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83067 - Installer crashes when attempting to load packages on Dell Optiplex GX110
Summary: Installer crashes when attempting to load packages on Dell Optiplex GX110
Keywords:
Status: CLOSED DUPLICATE of bug 76123
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 22:18 UTC by Matt Evett
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:29 UTC


Attachments (Terms of Use)

Description Matt Evett 2003-01-29 22:18:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.0.1) Gecko/20020823
Netscape/7.0

Description of problem:
Booting from the installation CD.  The entire installation process goes smoothly
until after packages have been selected for installation.  

Anaconda recognizes the hardware (I'm using an old Dell Optiplex GX111. 
Anaconda sees an Intel810 video card and a Dell M770 monitor).

The installation process is simple:
1. Select a generic 3-button mouse.
2. Choose to install a "personal desktop" (I also tried Workstation)
3. Choose to autopartition (I also tried manual partitioning)
4. Choose to "remove all partitions"
5. Select GRUB as the bootstrapper
6. Select DHCP to obtain IP address
7. Enable SSH (and DHCP)
8. Choose English as language
9. Select EST as the timezone
10. Set the su password and create one user account
11. Accept the default packages for installation

Anaconda now warns that the next step is not undoable.  I select OK.  The screen
changes to show two empty "progress bars", but within a few seconds, a dialog
box pops up with an error message:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.ph", line 149, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc=apply(func,self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(diskset)
 File "/usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
  lvm.vgactivate()
 File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath=1)
 File "/usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno12] Cannot allocate memory


I have used disk images from different mirror locations, and used 3 different CD
burners to create the installation CDs.  All fail in the same way.

I would certainly appreciate any feedback!  I've wasted far too many hours
trying to get this to work so that I can teach my students how to do the same
thing for a graduate course I'm teaching




Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Copied from description above:

Run the installation process:
1. Select a generic 3-button mouse.
2. Choose to install a "personal desktop" (I also tried Workstation)
3. Choose to autopartition (I also tried manual partitioning)
4. Choose to "remove all partitions"
5. Select GRUB as the bootstrapper
6. Select DHCP to obtain IP address
7. Enable SSH (and DHCP)
8. Choose English as language
9. Select EST as the timezone
10. Set the su password and create one user account
11. Accept the default packages for installation 

Actual Results:  Copied from description above:
Anaconda now warns that the next step is not undoable.  I select OK.  The screen
changes to show two empty "progress bars", but within a few seconds, a dialog
box pops up with an error message:

Traceback (most recent call last):
 File "/usr/lib/anaconda/gui.py", line 786, in handleRenderCallback
  self.currentWindow.renderCallback()
 File "/usr/lib/anaconda/iw/progress_gui.ph", line 149, in renderCallback
  self.intf.icw.nextClicked()
 File "/usr/lib/anaconda/gui.py", line 632, in nextClicked
  self.dispatch.gotoNext()
 File "/usr/lib/anaconda/dispatch.py", line 150, in gotoNext
  self.moveStep()
 File "/usr/lib/anaconda/dispatch.py", line 215, in moveStep
  rc=apply(func,self.bindArgs(args))
 File "/usr/lib/anaconda/packages.py", line 430, in turnOnFilesystems
  partitions.doMetaDeletes(diskset)
 File "/usr/lib/anaconda/partitions.py", line 1110, in doMetaDeletes
  lvm.vgactivate()
 File "/usr/lib/anaconda/lvm.py", line 54, in vgactivate
  searchPath=1)
 File "/usr/lib/anaconda/iutil.py", line 66, in execWithRedirect
  childpid = os.fork()
OSError: [Errno12] Cannot allocate memory


Expected Results:  Installation should have completed successfully.

Additional info:

Comment 1 Michael Lee Yohe 2003-01-30 15:24:52 UTC
This appears to be a duplicate of Bug 76123.  The problem is that there is not
enough memory to process the transactions that are to be executed by the
installer.  Anaconda, in GUI mode, requires at least 64M of memory.

You can alternatively attempt to install Red Hat Linux 8.0 in text mode by
specifying "linux text" at the SYSLINUX prompt upon first boot.

Comment 2 Matt Evett 2003-02-06 21:44:45 UTC
The suggested work-around does the job.  I have successfully installed 8.0. 
Thanks to Mr. Yohe for the help!

*** This bug has been marked as a duplicate of 76123 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:51:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.