Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83025 - aspell's HTML/SGML mode is inoperative
Summary: aspell's HTML/SGML mode is inoperative
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: aspell
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 17:38 UTC by Mark Cornick
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-20 18:08:47 UTC


Attachments (Terms of Use)

Description Mark Cornick 2003-01-29 17:38:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030120

Description of problem:
aspell offers several alternative modes for checking spelling, such as an email
mode and an HTML/SGML mode. The HTML/SGML mode does not operate in the version
shipped in Phoebe.

Version-Release number of selected component (if applicable):
aspell-0.33.7.1-20

How reproducible:
Always

Steps to Reproduce:
1. Obtain an HTML/SGML file of some sort. Call it testfile.html
2. aspell --mode=sgml -c testfile.html
3. Await results.
    

Actual Results:  No results. aspell produces no output or feedback of any kind.

Expected Results:  aspell should start its regular spell check routine, such as
one would see if not using HTML/SGML mode (aspell --mode=none -c testfile.html)

Additional info:

bug 80757 suggests upgrading aspell. I can report that aspell-0.50.3 fixes this bug.

Comment 1 Chris Ricker 2003-02-01 01:14:22 UTC
I second this as well.  aspell 0.33 -c -H fails miserably when checking XML
(looks like a recursion loop infinitely allocating memory), and aspell 0.5x -c
-H works

Bug 80757 and Bug 77617 are basically the same bug as this

Comment 2 Eido Inoue 2003-02-20 18:08:47 UTC
aspell will be upgraded in the next release


Note You need to log in before you can comment on or make changes to this bug.