Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83018 - The <cctype> header is wrong and doesn't work
Summary: The <cctype> header is wrong and doesn't work
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libstdc++
Version: 7.3
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 16:42 UTC by Jack Lloyd
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-01-30 11:46:24 UTC


Attachments (Terms of Use)

Description Jack Lloyd 2003-01-29 16:42:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021128

Description of problem:
Essentially, the <cctype> header does not put the things that should be there
(isdigit, toupper, etc) into the std namespace. For an example of how to do this
correctly, look at the cctype header included in GCC 3.2.


Version-Release number of selected component (if applicable):
  110

How reproducible:
Always

Steps to Reproduce:
1. Attempt to compile this code:
-----START CODE-----
#include <cctype>

int main()
   {
   char c = 'x';
   if(std::isdigit(c))
      return 0;
   else
      return 1;
   }
-----END CODE-----

2. It won't compile with GCC 2.96, but will with 3.0.4, 3.1, 3.2, and any other
ISO C++ compilant compiler/library.


Actual Results:  Won't compile because of the header problem.

Expected Results:  Should compile.


Additional info:

Check the GCC 3.2 cctype header for what should be a drop-in replacement.

Comment 1 Jakub Jelinek 2003-01-30 11:46:24 UTC
That's expected. GCC 3.0 was the first one to honour std namespace.


Note You need to log in before you can comment on or make changes to this bug.