Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83017 - man displays non-ascii hyphens under en_US.UTF-8
Summary: man displays non-ascii hyphens under en_US.UTF-8
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: groff
Version: 8.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 16:24 UTC by Brock Sides
Modified: 2007-04-18 16:50 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-08 00:20:20 UTC


Attachments (Terms of Use)

Description Brock Sides 2003-01-29 16:24:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

Description of problem:
Now that UTF-8 is the default LANG setting in Red Hat 8.0, the hyphen character
that man displays is *not* ascii 45, the character that you can create with your
keyboard. So, for example, you're reading "man grep", and you type "/-i" to skip
down and see what the -i flag does, you get "Pattern not found".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Make sure you're LANG variable is set to en_US.UTF-8
2. man grep
3. search for the -i flag by typing "/-i"
    

Actual Results:  "Pattern not found"

Expected Results:  The pager should skip forward to the next occurance of "-i",
telling me 
what the -i flag does.

Additional info:

Debian and SuSE work around this by adding the following lines to man.local:

.if '\*[.T]'utf8' \{\
.  char \- \N'45'
.  char - \N'45'
.\}

Comment 1 Bill Nottingham 2003-01-30 05:19:32 UTC
*** Bug 83020 has been marked as a duplicate of this bug. ***

Comment 2 Florian La Roche 2003-02-08 00:20:20 UTC
This is fixed with the newest groff rpm in rawhide.

greetings,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.