Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83010 - [GinGin beta 3] - tg3 NICs fail to obtain DHCP IP during boot
Summary: [GinGin beta 3] - tg3 NICs fail to obtain DHCP IP during boot
Keywords:
Status: CLOSED DUPLICATE of bug 80322
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dhcp
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
: 83011 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 15:09 UTC by Larry Troan
Modified: 2016-04-18 09:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:29 UTC


Attachments (Terms of Use)

Description Larry Troan 2003-01-29 15:09:11 UTC
On Dell PowerEdge 6600/6650\'s with their embedded Broadcom 5703, the system
fails to obtain an IP address during boot. When bringing up the device during
boot, system gives an error, says to check the cable.

Once system boots, you can \"service network restart\" and the device (eth0)
will obtain and IP adress with no problems. 
----------
Action by: jgarzik
This is a symptom of a buggy DHCP client, that does not wait for the link to
show up.  The BCM570x chips have a phy init sequence that takes a long time to
process, and some DHCP clients written during the 10/100 days have not been
updated to support these slower phy init sequences.  If this is \"pump\", the
Red Hat DHCP client used by the installer (and _only_ by the installer... not
used after install), then this is a bug I just hit in the lab yesterday.


Status set to: Waiting on Tech

----------
Action by: mdomsch
yes, this issue was registered testing only the installer (hence pump), not
using dh-client after install.


----------
Action by: mdomsch
oh, my mistake, comment immediately preceeding was for a different issue. 
Please ignore.


----------
Action by: jhull
The system picked up an IP just fine during install (I did an NFS install). Only
when the system boots after the OS is installed does the problem exist.


OPENED BUGZILLA PER JEFF GARZIK AGAINST PUMP. 
THIS IS ISSUE TRACKER 14019 WITH DELL ASSIGNED SEVERITY 1

Will also open Bugzilla against dhclient per Jeff to cover operational problem.

Comment 1 Larry Troan 2003-01-29 15:26:23 UTC
Bugzilla 83011 also opened against dhclient per jeff garzik (operational code as
compared to install code).

Comment 2 Larry Troan 2003-01-29 15:28:04 UTC
Dell has reduced sevarity to 2 in latest issue tracker update. Reflecting this
in Bugzilla.

Comment 3 Eido Inoue 2003-01-29 19:51:11 UTC
As the bug report says that the problem exists AFTER install, the culprit should
be dhcpclient, not pump.

Comment 4 Elliot Lee 2003-01-29 22:03:23 UTC
dhcp package, not dhcpcd, produces dhclient binary rpm.

Comment 5 Daniel Walsh 2003-01-29 22:15:42 UTC
This is not a problem with dhcp I believe.  Basically they are getting an error 

eth0 failed; no link present.  Check cable?

This comes from the ifup script.  The ifup script is calling the check_link_down
function in /etc/sysconfig/network-scripts/network-functions.

This code runs the following

    if [ -x /sbin/mii-tool ]; then
        LC_ALL=C ip link show $1 2>/dev/null| grep -q UP || ip link set $1 up
>/dev/null 2>&1
	# wait for link to come up
	sleep 5
	/sbin/mii-tool $1 >/dev/null 2>&1 || return 1
        ...


/sbin/mii-tool is probably returning an error like
eth0: no link

So we need to know why the card is taking more than 5 seconds to get up or put
the script in a loop to check for more than 5 seconds.

Dan
Either way this bug should be reassigned to initscripts

Comment 6 Bill Nottingham 2003-01-30 05:18:50 UTC
*** Bug 83011 has been marked as a duplicate of this bug. ***

Comment 7 Bill Nottingham 2003-01-30 05:20:12 UTC
*** This bug has been marked as a duplicate of 80322 ***

*** This bug has been marked as a duplicate of 80322 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:51:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.