Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8301 - regular bombs
Summary: regular bombs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver
Version: 6.1
Hardware: alpha
OS: Linux
medium
low
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-09 00:21 UTC by michal
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-05 06:24:51 UTC


Attachments (Terms of Use)

Description michal 2000-01-09 00:21:19 UTC
xscreensaver-3.17-5 from 6.1/Alpha with unwavering regularity
leaves core files.  When checked with 'gdb -core core' they provide
the following information:

.............

Core was generated by `rd-bomb -root'.
Program terminated with signal 11, Segmentation fault.

warning: Hit heuristic-fence-post without finding

warning: enclosing function for address 0x120002ee8
This warning occurs if you are debugging a function without any symbols
(for example, in a stripped executable).  In that case, you may wish to
increase the size of the search with the `set heuristic-fence-post'
command.

Otherwise, you told GDB there was a function where there isn't one, or
(more likely) you have encountered a bug in GDB.
#0  0x120002ee8 in ?? ()

......

It is always 'rd-bomb'.  It looks like an apt name. :-)

  Michal
  michal@harddata.com

Comment 1 Bill Nottingham 2000-02-05 06:24:59 UTC
I can't reproduce this with xscreensaver-3.23-3 from Raw Hide;
it runs without problems. Then again, the rd-bomb code hasn't
changed. Does the rd-bomb from Raw Hide work for you?


Note You need to log in before you can comment on or make changes to this bug.