Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 83 - /etc/rc.d/init.d/httpd restart doesn't always start
Summary: /etc/rc.d/init.d/httpd restart doesn't always start
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache
Version: 5.2
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-16 00:47 UTC by Edward Schlunder
Modified: 2012-06-19 22:19 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1998-12-16 17:15:23 UTC


Attachments (Terms of Use)

Description Edward Schlunder 1998-11-16 00:47:28 UTC
Sometimes when you do a /etc/rc.d/init.d/httpd restart, the
httpd server doesn't start back up properly because the port
is still busy. There needs to be a slight wait between
shutting down and then trying to start back up.

Comment 1 seva 1998-11-19 14:25:59 UTC
I can confirm this.  Don't know if the reason is right or not, but
restart doesn't alwasy work.

Although most of the time you want 'reload' option.

/Seva

Comment 2 zblaxell 1998-12-13 01:04:59 UTC
Isn't that "slight wait" on the order of 120 seconds?

One could use something like netcat to try to bind the port in a loop,
pausing a few seconds at a time until it succeeds.  Then again, httpd
could do that for us anyway.

Comment 3 Preston Brown 1998-12-16 17:15:59 UTC
The next release of apache will include a httpd init file which is
closely modeled after the 'apachectl' utility that the apache group
ships, which we have found people are familiar with.  It does server
restarts in a different way -- much more like server reloads.
Hopefully this will fix the problem.  If you want an explicit 'stop'
followed by a 'start' you will specify it as such.


Note You need to log in before you can comment on or make changes to this bug.