Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82996 - serial mice aren't detected
Summary: serial mice aren't detected
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kudzu
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks: 79579
TreeView+ depends on / blocked
 
Reported: 2003-01-29 13:13 UTC by Marius Andreiana
Modified: 2014-03-17 02:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-12 19:41:45 UTC


Attachments (Terms of Use)
kudzu output (deleted)
2003-02-11 18:16 UTC, Michael Schwendt
no flags Details
kudzu2 output (deleted)
2003-02-11 18:17 UTC, Michael Schwendt
no flags Details
kudzu output (deleted)
2003-02-12 10:06 UTC, Marius Andreiana
no flags Details
kudzu2 (deleted)
2003-02-12 10:08 UTC, Marius Andreiana
no flags Details

Description Marius Andreiana 2003-01-29 13:13:55 UTC
Seems all serial mice aren't detected ( I've tried two, somebody confirmed it on
phoebe list ).

They work if manually configured with mouseconfig.

Related bugs:
bug #865147, #47757

Comment 1 Michael Schwendt 2003-01-29 15:29:20 UTC
Confirmed. Fails for me with both Phoebe 8.0.92 and 8.0.93. Copying from bug #80332:

  Probing for mouse: No - mouse

Suffice to say, mouse detection worked flawlessly with older versions of Red Hat
Linux, including the Limbo and (null) betas. My mouse is a classic 3-button
serial mouse from Logitech on /dev/ttyS1. Kernel info from Valhalla:

02f8-02ff : serial(auto)
03f8-03ff : serial(auto)

Serial driver version 5.05c (2001-07-08) with MANY_PORTS MULTIPORT SHARE_IRQ
SERIAL_PCI ISAPNP enabled
ttyS0 at 0x03f8 (irq = 4) is a 16550A
ttyS1 at 0x02f8 (irq = 3) is a 16550A

Comment 2 Bill Nottingham 2003-02-11 15:47:41 UTC
Please download http://people.redhat.com/notting/kudzu/kudzu,
and run (as root, with gpm disabled, on the console)

kudzu -p -b serial

Thanks.

Comment 3 Bill Nottingham 2003-02-11 17:32:58 UTC
Also, try kudzu2 in the same location.

Comment 4 Michael Schwendt 2003-02-11 18:16:04 UTC
Created attachment 90005 [details]
kudzu output

kudzu ran on Phoebe 8.0.93

Comment 5 Michael Schwendt 2003-02-11 18:17:19 UTC
Created attachment 90006 [details]
kudzu2 output

kudzu2 ran on Valhalla via a chroot'ed Phoebe 8.0.93

Comment 6 Marius Andreiana 2003-02-12 10:06:30 UTC
Created attachment 90028 [details]
kudzu output

Comment 7 Marius Andreiana 2003-02-12 10:08:25 UTC
Created attachment 90029 [details]
kudzu2

Comment 8 Marius Andreiana 2003-02-12 10:10:36 UTC
See above outputs on clean install of phoebe2

Comment 9 Bill Nottingham 2003-02-12 19:41:45 UTC
Fixed in 0.99.94-1.


Note You need to log in before you can comment on or make changes to this bug.