Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82993 - yelp segfault on phoebe upgrade
Summary: yelp segfault on phoebe upgrade
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: yelp
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 79578
TreeView+ depends on / blocked
 
Reported: 2003-01-29 12:37 UTC by Miloš Komarčević
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-19 18:30:19 UTC


Attachments (Terms of Use)
my configuration file .gtkrc.mine (deleted)
2003-02-03 19:06 UTC, Miloš Komarčević
no flags Details

Description Miloš Komarčević 2003-01-29 12:37:11 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030115

Description of problem:
yelp segfaults on two machines that were
upgraded to phoebe2 from 8.0

it works on a fresh install

Version-Release number of selected component (if applicable):
2.1.4-1 and 2.2.0-1

How reproducible:
Always

Steps to Reproduce:
1.start yelp or gnome-help
2.
3.
    

Actual Results:  segfault

Additional info:

(yelp:2912): GLib-GObject-CRITICAL **: file gobject.c: line 1319 (g_object_ref):
assertion `G_IS_OBJECT (object)' failed
 
(yelp:2912): Gtk-CRITICAL **: file gtkstyle.c: line 1623
(_gtk_style_peek_property_value): assertion `GTK_IS_STYLE (style)' failed

Comment 1 Alexander Larsson 2003-01-31 11:17:51 UTC
It doesn't seem to do that on my machine, although its not an upgrade.
Can you try upgrading to the latest versions of: yelp, gtkhml2 and libgnome from
rawhide?

If that doesn't help, could you start yelp in gdb and get a backtrace from where
it segfaults?


Comment 2 Miloš Komarčević 2003-01-31 12:27:14 UTC
Upgrading to rawhide packages did not help.
I have:
yelp-2.2.0-1
gtkhtml2-2.2.0-1
libgnome-2.1.90-2

The backtrace is already available in GNOME's bugzilla:

http://bugzilla.gnome.org/show_bug.cgi?id=104609

Comment 3 Miloš Komarčević 2003-01-31 12:41:28 UTC
I have just seen that there was a newer libgnome in rawhide
that was not available on my mirror.
Unfortunately libgnome-2.2.0.1-1 did not help, the result is
the same.

Comment 4 Miloš Komarčević 2003-01-31 12:50:27 UTC
Same with yelp-2.2.0-2 and gtkhtml2-2.2.0-2

Comment 5 Miloš Komarčević 2003-01-31 18:44:27 UTC
I've also figured out that it works if I create a new user
and/or start fresh without any GNOME configuration files,
so it's probably some of the old settings that clash.

Comment 6 Alexander Larsson 2003-02-03 16:17:53 UTC
Could you attach a copy of the config files that make it crash?


Comment 7 Miloš Komarčević 2003-02-03 19:06:18 UTC
Created attachment 89814 [details]
my configuration file .gtkrc.mine

I have narrowed it down to my .gtkrc.mine 
I've had it since RHL 7.1 and I've also included it
in my .gtkrc-2.0 when I upgraded to 8.0, and yelp
and all other GTK2 apps worked fine...

Comment 8 Alexander Larsson 2003-02-19 17:12:58 UTC
I also get the crash when i use that as my ~/.gtkrc-2.0. Could possibly be a
gtk+ bug.

Comment 9 Alexander Larsson 2003-02-19 17:15:19 UTC
Strange. I can reproduce it with this minimal .gtkrc-2.0:

style "default"
{
  fg[NORMAL] = { 0.0, 0.0, 0.0 }
}

class "*" style "default"


Comment 10 Owen Taylor 2003-02-19 17:32:36 UTC
Alex: can you get a backtrace with debug symbols?


Comment 11 Alexander Larsson 2003-02-19 17:47:13 UTC
Ah, this is a libgtkhtml bug that has been fixed in CVS. it was sometimes
unreffing a style to much. I'll build a fixed package.

Comment 12 Alexander Larsson 2003-02-19 18:30:19 UTC
Should be fixed in gtkhtml2-2.2.0-5.


Note You need to log in before you can comment on or make changes to this bug.