Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82987 - RFE: More available file descriptors for Squid per default
Summary: RFE: More available file descriptors for Squid per default
Keywords:
Status: CLOSED DUPLICATE of bug 72896
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: squid
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 11:11 UTC by Janne Pikkarainen
Modified: 2014-08-31 23:24 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:51:28 UTC


Attachments (Terms of Use)

Description Janne Pikkarainen 2003-01-29 11:11:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20021218

Description of problem:
Squid bundled with Red Hat seems to have only 1024 file descriptors available
per default. This limit can be easily raised by adjusting DEFAULT_FD_SETSIZE
parameter from the Squid's configure script & OPEN_MAX value from
/usr/include/linux/limits.h and after that recompiling Squid. 

Is there a reason why the default maximum value is so low? If there isn't, could
it be pumped up in the forthcoming releases of Red Hat?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Red Hat Linux 8.0 (or whatever version, I think)
2. Start Squid.
3. See how your highly loaded proxy server starts to run out of file
descriptors, thus slowing down the server.
    

Actual Results:  After running Squid for couple of minutes it ran out of file
descriptors.

Expected Results:  Squid shouldn't run out of file descriptors. Recompiling
Squid with higher maximum values fixed the problem.

Additional info:

Comment 1 Jay Fenlason 2003-01-29 16:16:46 UTC
See bug #72896 for attempted resolution.

*** This bug has been marked as a duplicate of 72896 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:51:28 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.