Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82962 - generated libtool fails on Irix std C++
Summary: generated libtool fails on Irix std C++
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libtool
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-29 00:02 UTC by Wagner T. Correa
Modified: 2007-04-18 16:50 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-12-20 07:25:39 UTC


Attachments (Terms of Use)

Description Wagner T. Correa 2003-01-29 00:02:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021212

Description of problem:
The libtool file generated on Linux doesn't work on Irix when compiling a
library written in standard C++.

To compile such a library on Irix, you have to pass the flag -LANG:std to the
compiler and the linker.  But libtool thinks that that flag specifies a path to
search for libraries.

This is a known problem, and in libtool there is an attempt to fix it:

      # The native IRIX linker understands -LANG:*, -LIST:* and -LNO:*
      # so, if we see these flags be careful not to treat them like -L
      -L[A-Z][A-Z]*:*)
        case $with_gcc/$host in
        no/*-*-irix*)
          compile_command="$compile_command $arg"
          finalize_command="$finalize_command $arg"
          ;;

The problem is that earlier in the libtool file with_gcc is defined as blank,
instead of defined as "no":

# Is the compiler the GNU C compiler?
with_gcc=


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. write a standard C++ library
2. create a tarball on Linux
3. try to compile the library on Irix
    

Actual Results:  The linking phase will fail because the -LANG:std flag is not
passed correctly to the linker.

Expected Results:  libtool should have defined with_gcc=no.

Additional info:

If you change libtool so that with_gcc=no, then the linking phase succeeds.

Comment 1 Jens Petersen 2003-05-01 14:45:37 UTC
I recommend to report this problem on bug-libtool@gnu.org.

Comment 2 Jens Petersen 2003-07-08 12:41:53 UTC
Looks like this is fixed in libtool-1.5:

      -L[A-Z][A-Z]*:*)
	case $with_gcc/$host in
	no/*-*-irix* | /*-*-irix*)
	  compile_command="$compile_command $arg"
	  finalize_command="$finalize_command $arg"
	  ;;
	esac

libtool-1.5 is now in rawhide - could you try with that please?


Note You need to log in before you can comment on or make changes to this bug.