Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82952 - wine dosn't work on kernel 2.4.20-2.2{6,7} and locks ps,top,killall etc
Summary: wine dosn't work on kernel 2.4.20-2.2{6,7} and locks ps,top,killall etc
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel
Version: 1.0
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 22:12 UTC by Michael Stefaniuc
Modified: 2007-04-18 16:50 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-02 07:03:37 UTC


Attachments (Terms of Use)
output of Sysreq-t after the wine/ps/top/killall process locked up (deleted)
2003-01-28 22:14 UTC, Michael Stefaniuc
no flags Details
remove FASTCALL from vm_ in lnclude/linux/mm.h (deleted)
2003-01-28 23:39 UTC, Michael Stefaniuc
no flags Details | Diff
sysreq-t output for the 2.4.20-2.27 with the patch applied (deleted)
2003-01-28 23:43 UTC, Michael Stefaniuc
no flags Details

Description Michael Stefaniuc 2003-01-28 22:12:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
I recompiled the 2.4.20-2.2{2,6,7} kernels on a up2date RHL 7.3 from the
kernel-source rpm using the athlon config from the configs directory.
Starting wine on the 2.4.20-2.2{6,7} kernel dosn't work; it just hangs without
spitting out the normal warnings it spits out on startup. The wine process can't
be terminated by CTRL-C nor moved into background. killall and top just hang and
ps outputs the details for the processes with pid smaller then the pid of the
wine process and then hangs too.
Before starting wine ps/top/killall just work fine.
The 2.4.20-2.22 kernel works just fine without exhibiting any of the above problems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot a 2.4.20-2.2{6,7} kernel
2. start wine
3. start top/ps/killall
    

Actual Results:  wine, top, ps ,killall hangs

Expected Results:  they should not hang

Additional info:

wine is latest CVS but that shouldn't matter.
I'll attach the output of Sysrq-t

Comment 1 Michael Stefaniuc 2003-01-28 22:14:45 UTC
Created attachment 89663 [details]
output of Sysreq-t after the wine/ps/top/killall process locked up

Comment 2 Ben LaHaise 2003-01-28 22:24:08 UTC
Note: may be related to FASTCALL macros interacting with gcc 2.96.  Can remove
them for older gcc.

Comment 3 Michael Stefaniuc 2003-01-28 23:39:49 UTC
Created attachment 89668 [details]
remove FASTCALL from vm_ in lnclude/linux/mm.h

As requested i tried this patch without succes.

Comment 4 Michael Stefaniuc 2003-01-28 23:43:16 UTC
Created attachment 89669 [details]
sysreq-t output for the 2.4.20-2.27 with the patch applied

Comment 5 Michael Stefaniuc 2003-01-28 23:45:43 UTC
Forgot to say that i did a "make clean" after applying the patch

Comment 6 Michael Young 2003-01-29 13:37:44 UTC
I am seeing the killall problem on phoebe2+rawhide packages for kernel -2.27
when the shutdown stops at the "sending TERM signal to all processes" stage. The
-2.25 kernel works fine.

Comment 7 Arjan van de Ven 2003-02-01 13:09:42 UTC
it looks like -2.30 works ok here... should be in rawhide now.

Comment 8 Michael Stefaniuc 2003-02-01 21:10:46 UTC
Just tested it and wine works just fine. You can close the bug.

Comment 9 Ingo Molnar 2003-02-02 07:03:37 UTC
So the signal fixes in 2.30 did the trick - great.


Note You need to log in before you can comment on or make changes to this bug.