Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 82931 - redhat-config-packages hangs when installing kernel support
Summary: redhat-config-packages hangs when installing kernel support
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-01-28 16:31 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-02-23 20:58:55 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-01-28 16:31:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2) Gecko/20021127

Description of problem:
Seeing major anomolies with RPM. I this case, tried to install kernel support
using redhat-config-packages on a minimal system (smallest footprint image was
installed in anaconda). Selected kernel (4 packages). Pressed update. Get
"Preparing system update" dialog. When progress bar get to 100%, app hangs. Text
under bar says "Computing package dependencies". Can kill app and all seems ok.
May be another ramificaiton of the comment I added to 80751, where dialog goes
away with no further output. Suspect instability in RPM is the cause... 

I needed kernel support to get tk installed. When installing tk from the command
line, RPM reports 2 bars of 100% and then hangs...

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start app
2.select kernel support
3.press update
    

Actual Results:  hangs with 100% progress bar

Expected Results:  no hang

Additional info:

Comment 1 Need Real Name 2003-01-28 16:35:33 UTC
Strike the installing from command line comment. When I copied the file to disk,
it installed ok. RPM must not like installing when current directory is on the
CD-ROM.

Comment 2 Jeremy Katz 2003-02-09 21:49:08 UTC
If you type dmesg, do you see errors relating to reading from the cdrom?

Comment 3 Need Real Name 2003-02-11 15:58:29 UTC
No errors from the CD-ROM. In fact, it hangs prior to prompting for any
insertions. Ran dmesg prior and after hang, no new messages appended to log.

BTW, I am up to date per rhn. Should I try some rawhide RPM packages?

Comment 4 Need Real Name 2003-02-11 16:53:19 UTC
Tried rawhide rpm and rpm-python 4.2.66, no joy. I hear that rpm now uses futex.
How would I go about seeing if rpm is hung?

Comment 5 Jeremy Katz 2003-02-23 20:58:55 UTC
To use rawhide rpm, you'll also have to use rawhide redhat-config-packages (and
some others probably).   Was probably due to interactions between different rpm
versions used by redhat-config-pcakages and the rhn-applet which are fixed now
(or just having a stale rpm lock from something else, but haven't seen that with
rawhide in a while)


Note You need to log in before you can comment on or make changes to this bug.