Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8293 - authentication fails
Summary: authentication fails
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-08 15:53 UTC by raya
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-20 02:44:31 UTC


Attachments (Terms of Use)

Description raya 2000-01-08 15:53:11 UTC
I have been using up2date since Nov and has worked fine, I attempted
to use it last night and I now get the loging failure. I did notice
that it is attempting to login to dell2.redhat.com. My configuration is
as follows:

User:
User ID: raya@directlink.net
Password: 439ae8205c78eb45

Retrieval:
Server: priority.redhat.com
Program: /up2date/server.cgi
Override version Red Hat Linux 6.1
Package storage directory /var/spool/up2date

Exceptions blank

Other comments:
The last four update announcements by Red Hat were not in the
priority update directory though I was able to retrieve them from the
normal updates having to try several times during the day
to find a time when the the ftp server was not maxed out with users.
I purchased the RH 6.1 Deluxe with the priority updates feature
that would forgo the frustration of repeated attempts to login
to an overworked ftp site.  It did work for a while but alas the
last few weeks it has been of no value to me and now I'm not even
able to log into the server.

Comment 1 Kirk 2000-01-15 15:52:59 UTC
It should also be noted that when the priority auth. fails, the message says
that anyone can point to ftp.redhat.com and get the same service, on a first
come first serve basis.  Doing so produces nothing but errors.

Comment 2 raya 2000-01-15 16:00:59 UTC
I have since discovered that if I just keep clicking the connect button that
it will eventually connect.

Comment 3 Preston Brown 2000-01-18 20:34:59 UTC
point to ftp.redhat.com, where you do not need to authenticate to connect.

Comment 4 raya 2000-01-19 01:16:59 UTC
ftp.redhat.com is a site where any user can get the latest updates, which means
you may have to try for a while as the server is usually very busy.

I purchased the Deluxe version of 6.1 which is suppose to have 180 days of
priority downloads. Well 180 days have not gone by and I can't authenticate
on the server that I was told to use for the 'priority' server. This was working
a few weeks ago but now is failing. The only thing I can think of on my end that
has changed is I put on the latest PAM package. Has that broken the
authentication?

Comment 5 Preston Brown 2000-01-19 18:46:59 UTC
make sure your username and password are included in the Update Agent
configuration.  Otherwise authentication at priority.redhat.com will fail.

Comment 6 Kirk 2000-01-19 19:26:59 UTC
I am not (and should not be) authorized, but I used ftp.redhat.com last night
and it worked fine.

Thanks!

Comment 7 raya 2000-01-20 01:07:59 UTC
OK, let's start over.
I have a valid userid and password. which was supplied to me by
Red Hat.
I put the userid and password in the up2date configuration.
That was in December. It worked fine, authenticated and downloaded
files into /var/spool/up2date.

When I opened this bug report, it had quit working.

When something that WAS working suddenly STOPS working and I have not changed
anything, then I expect a better answer than 'verify userid and passwd are
correct'. I had already checked that before opening this bug report.

Comment 8 Preston Brown 2000-01-20 02:44:59 UTC
in december, the system was *not* authenticating.  Authentication wasn't turned
on; we were still in a trial period.  Authentication was turned on in early
January.

Authentication works here, and for other users, so one of two things is
possible:

1. you have mis-entered your username and/or password
2. there is some problem with your username and/or password, and they somehow
got out of the red hat support system.  In this case you will need to contact
Red Hat Support to get the issue resolved.

This is not a software problem, and I am sorry if you have been lead to believe
so.  Please try again this evening (as I said above, there _were_ some
authentication issues a week ago where legit accounts were being denied access)
and if you are still having trouble contact support.

Comment 9 raya 2000-01-20 03:04:59 UTC
OK,
I went back and read an email from Red Hat Priority FTP Service
Subject: CORRECTION: Access rules for priority.redhat.com

I changed my password accordingly and it appears to be working now!

I was mis-lead by the fact it WAS working. I didn't know the AUTHENTICATION
was disabled on the server.

Thanks for you patientce.


Note You need to log in before you can comment on or make changes to this bug.